Mixdown exports too quiet

Running Cubase LE 5 with a Tascam US-2000 interface.

I notice in the studio that when playing a mixdown in Cubase on my monitors, it’s much louder than playing any other items like CDs, computer music files, Youtube music files, etc. The Cubase playback sounds fat and rich, then when I export a wav file, it’s at a lower volume and not as saturated. I think the wav file may actually be ‘normal’ and I’ve got something wrong in the audio/playback/monitoring settings for Cubase. Have seen this issue on other forum topics, possible doubling up of outputs and monitoring, bus settings, etc., but I’m not an engineer and I can never find clear instructions applicable to LE 5. Any help much appreciated!

I have compressors on most tracks to bring up the gain. Important to have a good compressor like PSP Xenon or L2 in the output bus.
The nature of modern music. No dynamics, all blasting all the time.
Has a lot to do with cars. In a car the soft parts are just not heard at all, so everything needs to be blasting to be heard.

I bet.