Mixed Scaling DPI Bug/Issues

I have 2 4k screens, one is set to 150% scaling and the other to 175% in Windows 10.

This causes a number of recurring scaling issues in Nuendo with things in the main (150%) window often appearing with the wrong scaling but reacting as if the scaling was correct (for example: menus appear 25% bigger but react to the mouse pointing where they ‘should’ be)

Here’s an easily reproduced one:

  1. Drag plugin window over to 175% screen
  2. Ctrl-click a track to open colorize menu
  3. Colorize menu seemingly doesn’t appear, unless you shrink the project window to one side and then you can see it was appearing underneath and at the wrong scaling (see photo)
  4. Drag plugin window back to main 150% screen
  5. Colorize menu opens as normal.

Does anyone else use different scaling rates on their monitors and find similar problems?

Cheers!

Just a small update: Switching on HiDPI ‘fixes’ this issue.

I say ‘fixes’ because it then makes the majority of the plugins I use far too small - and the resize window option is comically broken for nearly all of them.

So in conclusion: Either have HiDPI on and broken looking plugins, or turn it off and have broken window scaling :man_shrugging:

Great. Regarding your plugins, have you tried this solution ? (Only available when HiDPI is on) Cubase 11: Using DPI-unaware plug-ins on Windows – Steinberg Support

Hi Armand thanks for your reply.

I did indeed have a look at that page before, but unfortunately the suggestions on there all bring their own issues:

  • Use the generic plug-in editor: Right-click on the plug-in toolbar ▸ Switch to Generic Editor

This doesn’t work for Kontakt (one of my main plugins)

  • Switch off HiDPI mode in Cubase’s Preferences ▸ General.

This brings back the previous scaling issues

Use the plug-in without enabling window resizing and live with the tiny size.

I’m working on a 4k screen and my eyes are old and tired, I wish I could live with the tiny size! Current workaround is to use the windows magnifier but 5 minutes of that gives me a major headache for some reason. It’s not ideal.

  • Use the plug-in on a secondary HD monitor, if available.

My other monitor is also 4K, and even further away (hence why the scaling is set higher). If Steinberg would like to donate a third monitor to me I would be happy to use that :wink:

I get the impression from that page that Steinberg is washing their hands of non DPI-aware plugins, and if the vendors won’t sort them out then we’re stuck with them as they are. Could you confirm whether there are plans to address this issue and make legacy plugins more usable on high res screens?

Hi Ed

Thanks for your reply. Actually the main thing you should try on this page is the very first one “Allow Window to be Resized”. Have you tried that one specifically?

If a vendor’s plugin is not HiDPI compatible we can’t magically make them HiDPI compatible. The main option we have is the one I’m pointing to which will allow the HiDPI-Unaware plugin to be opened as an HiDPI-Unaware Window. Unfortunately it also brings side-effects sometimes even with this mode. We have been in touch with NI about that since last October and there is nothing else we can really do here, they have to solve those issues and make the plugins HiDPI-Aware. Afaik they are actively working on it though. It’s not an easy task on their side.

Yes sorry I should have been clearer - using the resize function doesn’t work for some major plugins in my workflow (e.g. Kontakt, Omnisphere, various Waves, SoundToys).

I understand that you can’t force plugins to be HiDPI compatible, but I 've heard that some competitors have found more successful ways (in some cases!) to handle this situation.

But let’s take Kontakt as a specific example: in Resize mode you get half of the plugin available at a good size, but the other half is cropped by the window. Is there no way that you could allow the user to choose or alter the method by which the window gets resized/cropped? (Apologies if that reflects my complete lack of knowledge in regards to how Nuendo works!)

Please do correct me if I’m wrong but this does feel like something Steinberg won’t fix as opposed to something it can’t fix.

I can understand why you feel like this shouldn’t be your problem because it’s not you guys who aren’t sorting your plugins out! But there are some of us using legacy plugins that mightnever be updated (or not for a seriously long time, as is seemingly the case with NI), who are now just stuck with plugins that are either tiny or unusable. Or we go back to non-HiDPI and then have to deal with the scaling issues that are at the top of this thread… You see my dilemma here!

EDIT: Actually I just realised that for several plugins as soon as you “Allow Window to be Resized” the plugin stops processing audio completely until you remove and insert it again. so that feature is just non-functioning for some plugins :man_shrugging:

1 Like

Hi @EdGray and thanks for your feedback.

“I understand that you can’t force plugins to be HiDPI compatible, but I 've heard that some competitors have found more successful ways (in some cases!) to handle this situation.”

I would gladly like to have more examples here. As far as we have been testing so far, we have identified that Studio One has very similar results and I believe Ableton Live are using a workaround mostly by not really being HiDPI-Aware but by manually rescaling their app. If you’re aware of any counter-example let us know so that we can investigate! :slight_smile:

The problem with Kontakt you’re descrbing is known to us and Native. It is so far a common understanding with NI that this bug is totally on their side. I cannot find the public announcement on their website anymore though.

Regarding your issue with stopped audio after using the “Allow Window to be Resized” function. Some plugins do not implement the VST protocol correctly and this is a known side-effect when resetting the window with the HiDPI-Unaware flag. It will only happen once and for all though so this feature is functioning in this regard. I was sure this side-effect was documented on the KB article nonetheless and will request an edit. :slight_smile:

I see your dilemma but for the plugins that are mentioned so far we cannot solve anything on our side.

Hi, thanks for your continued attention to this thread :slight_smile:

"I would gladly like to have more examples here. "

I’d recommend having a look at Bitwig. I just downloaded it to double check what I’d read previously was correct about how it handles plugins and it seems to do it quite well. From what I can tell the interface appears to be in high definition, and in the settings menu you can change the gui scaling independently from global Windows settings, which is pretty neat. HiDPI plugins such as Fabfilter all seem to work properly, and non-DPI aware plugins like Kontakt can be set independently to render at different sizes (relative to the main scaling setting, I think?). So I tested Kontakt and Waves plugins at 200% and they appeared much bigger. Blurry of course but far more usable than they are at regular size. If this kind of feature could make its way into Nuendo that would make a huge difference to the usability of legacy plugins.

This problem with Kontakt (et al) and rescaling in Nuendo may well be completely on NI’s side, but the guys at Bitwig seem to have found a solution that works (based on my admittedly limited testing)

Thanks for the clarification on the stopped audio issue - I’m in the middle of a complex project so can’t test it just yet but I presume that if I open a blank project and change those plugins to be resized then that change will happen in all my other projects as well?

Hi @EdGray

Thank you for contributing to improving our software!

We will investigate how Bitwig is implementing this. Fabfilters are VST3 and should behave rather optimally on Cubase and most DAWs. They are actually one of the best implementers of this technology.

Regarding the stopped audio issue. Yes it will apply on every project. Although it’s recommended to go through your main incompatible plugins in a blank project to test this feature at first, it’s more a matter of practicality (you just want to focus on this issue at once and then keep on your workflow). This will not damage your project. You can also simply reopen your project, or just reopen Cubase if this still doesn’t work. The issue is that some plugins do not reset their state correctly when we reopen the window as HiDPI-Unaware, that can lead to audio issue only with the current instance.

1 Like