Mixer and VST problems

I’m using Dorico 4.1 Pro. I would like to set up a bunch of VST synths, in addition to a couple of acoustic instruments played by NotePerformer or Halion. No matter what I do, the Mixer behaves erratically. First I simply used the NotePerformer playback template and added the other VSTis to the VST rack and assigned the different players (staffs) to them, each on their own MIDI channel. The playback is OK but the mixer routes the playback on wrong channel strips (I’m not talking about NotePerformer’s own mixer, I do know how that works). I then created a playback template with NotePerformer plus Family overrides for Sketch (the synth tracks are using Sketch instruments). Same problem: some of the instruments are using wrong channel strips in the mixer, and some are not there at all (but do play back). I tried replacing NotePerformer with Halion and creating a template with the Halion playback template, with Family override for Sketch instruments, No luck.
How can I create a Playback Template for a set of abstract staffs for arbitrary synthesizers (VSTis) with or without a sample player for acoustic instruments? Is it possible? Or is there a bug in the Mixer? Or am I doing something wrong or missing something?

Please load that project and then do Help > Create Diagnostics Report and post the corresponding zip file here. Also, please make a screenshot of the mixer and post. Thanks

In the mixer “Flute” represents all the Noteproformer woodwind staves but the Percussion channel, also from NotePerformer, is missing, and I can’t hear the percussion sounds… The instrument called “Beat”(Steinberg Groove Agent) plays back but its output is not shown on the corresponding channel strip. The diagnostic zip file is too large to be sent here (it’s 5.8 M and 4M is the maximum.). Where can I send it?

You can email it to Ulf at u dot stoermer at steinberg dot de.

It’s expected that you will see only a single fader in Dorico’s Mixer for NotePerformer; it provides only one output, and any balancing that you need to do within NotePerformer itself must be done in its own user interface.

Yes, I know; that’s not the problem here but the fact that there’s no channel strip for Groove Agent even though it plays back. (Or rather, there is - “Beat” - but it remains inactive even when Beat is sounding.) I do have a problem with NotePerformer, too, though - I can’t get it to play the orchestral percussion sounds I’ve put in the Percussion Kit - it insists on playing a Drum Kit although I don’t have Drum Kit set in the Percussion Kit edit page. But this is probably just some NotePerformer awkwardness and I need to find a setting to make it use the sounds I’ve selected (they’re basic sounds that do exist in NP).

Hi @kaleva ,
thanks for the data. According to the mixer xml, you have 1 NotePerformer instance, 2 Zebras, 1 Diva and 1 GrooveAgent. The Groove Agent actually has 32 outputs, but the Dorico mixer only shows the first stereo pair of Groove Agent. I can’t see the routing, but I suppose that the drum sounds of Groove Agent are not routed to the first stereo pair and therefore no activity is shown. Try to click in the mixer window at the top on Unused, that will show all outputs of each instrument. Do you see then on some audio channel signal of the drums?

Hi Ulf,

great - thank you so much. I’d missed those things. I just use the Groove Agent for a sketch drum part and I hadn’t looked into its editing functions. I now directed all the samples to the same output which indeed shows when Unused is selected in the mixer. Somewhat annoyingly, the channel strip is called Master (taken from GE) rather than by the name given to the Player in my project setup but it works now.

Thanks again,


Lähetetty iPadista

1 Like

Still having trouble with the mixer. I added Kontakt 5, and that, too, uses one output of many which can only be seen when Unused is selected in the mixer. Now, because the channel strips in the mixer window can’t be hidden one by one or moved to another location, I have tens of unused buses placed in between the active strips (all the 32 outputs of Groove Agent). The Mixer doesn’t respond well to mouse scrolling, and it’s difficult to get to the far-away channel strip. I can’t see the active output channel of Kontakt before a tedious scrolling…changing the size of the mixer…scrolling…changing the size— etc-. So the Mixer is almost useless now. Please make it more editable, like in a DAW (Cubase for example).

In the Endpoint Configuration dialog you can specify how many channels a VST instrument shall show in the mixer. The rest goes into the unused section

I see. Thanks. So what I wished is actually there - but now the problem is that the Edit Endpoint Configuration window is empty, and I don’t know how to add anything there (and what it is I should add). Even after reading the manual and watching the Discover Session on Playback Templates I don’t really understand what I should do. I find this Playback Template protocol difficult and clumsy - I would just like to add staves and assign synths and midi channels to them at will and not care about Dorico’s obligatory Players, Instruments, Expression Maps and so on. Perhaps it’s possible to make a Playback template for such work but I really don’t know how.

I don’t know why the endpoint configuration dialog would be empty. I hope @dspreadbury can help out here.

It’s probably because none of the instruments are assigned in the inspector.
What I would try is this: Set the PLAYBACK template to Silence in the Preferences. Forget the playback template for the time being. Load all the VST’s into the Rack that you want to use. Create the instruments you want to use. Select the instrument in PLAY mode in the list of instruments and then use the Inspector next to the VST tab to Route and assign the VST’s to the instruments you want and assign the appropriate midi channels. Most of the time this is probably going to be midi channel one…One stave/instrument mapped to one VST sound. Most VST’s will default to stereo out and you should see this reflected in the mixer. The endpoint configuration will show the instruments only when they have been assigned to a specific VST. You can then load in your Expression Maps if you have any or use a Default one. Save the project as a template song with no music in it, and then use it to start a new piece. I don’t even save my endpoint configurations because they are only necessary if you use a Playback Template, which I have suggested that you don’t need to bother with. At least at the start as you get used to how the whole thing works. If you need other VST’s from the ones in your saved Template Song you can add them as needed. Once you get the hang of this it should be easy. If you are using VEPro then there are some added things to deal with, especially if you want multiple outs, but the same principles apply. Just run VEPro in ‘uncoupled’ mode and save your VEPro template separately. Always load your VEPro template before Dorico, and when you boot up Dorico it should work automatically by connecting to the VEPro server.

I would start by using Change Instrument for each track in the Setup mode to change (say) the Flute track to a Flute, etc. to let Dorico set up the association and then move to play to (re)associate each instrument with VST’s and Endpoints.

Thank you! I will try to follow these instructions, but I have always assigned all the instruments to specific VSTis and MIDI channels in the VST rack - I wouldn’t hear them if I hadn’t. But the Endpoint Configuration window is empty.

And you could always work on a copy of your file so you’d have a safe backup if your method proved more to your liking. That’s what I usually do when trying something new.

I realized I was looking at the wrong window: I thought that you meant the Edit Endpoint Configuration window under the edit page of the Playback Template (this was when I was using the new Playback Template I’d created). The Endpoint Setup window in the VST Rack does show the configuration for each instrument. However, specifying the number of visible output channels has no effect. Whatever I write in it, the mixer shows only one channel strip, except in Unused mode when it shows all 32.

Thank you for your advice, @Grainger2001 and @Derrek. In fact I believe that I’d already proceeded more or less the way you suggested. I don’t think I can start from the “Silent” Playback Template if in addition to all the VST synths I’ll include NotePerformer (which often creates problems). I tried but it seemed impossible to get NotePerformer to allocate (NP) channels for individual percussion instruments if I added a Percussion Kit instrument afterwards. I think I need to start building the setup using the NotePerformer playback template. But I’ll make a separate “Template Song” for my VST-synths-only setups.

Hm, that area of the program is not my particular expertise and I also don’t have an appropriate computer at hand to try it out myself. Maybe you have to make the changes in that dialog, save, close and reopen the project in order for the change to take effect. I will try on Monday, when I’m back to office.

No, reopening doesn’t help. There’s an additional nuisance when the active channel strip is among the Unused ones: the Mute and Solo buttons in the Play window and in the Mixer window do not reflect each other. For example, it is not possible to mute or solo Groove Agent from the Play window, you’ll have to do that form the appropriate “unused” (actuallly used) channel strip in the Mixer window.

Okay, I tried it myself and specifying the number of audio outputs in the mixer does not work anymore. It still does in Dorico 3.5 but not in 4 anymore. So I filed this as a bug in our tracking system.