Model-E in Win7 64bit

A real blast from the past here, but I would really like to get the old girl working again. When I try to install Model-E, even from an update with the disc in the drive, the installer says the installation disc isn’t genuine when it is! Apparently this problem appeared when Vista came along and no one seems to have sorted it, because it is old stuff and unsupported. However, I have good reason to believe the software still works in Win 7, it is just the installer that is no good. Could a coder at Steinberg with an hour or two to spare fix it for the good of us long standing paying customers?

Had the same problem here. I like Model-E. Be nice if they could fix the install problem. Cheers!

Hmmmmm! Wonder why there hasn’t been any response to this other than a “me too”?

A couple of weeks later…still nothing…

If this is the same problem as I had with Plex then it has to do with the windows DVD drivers, I found an old CD-ROM drive and installed it from there

I have the same problem with both LM4 and Model E. I can’t believe Steinberg’s attitude on this one. This has been a problem for number of years now. Everyone seems to be shrugging their shoulders. Come on, can we have a solution, please.

The solution is to use a CD-ROM drive to install it, as the copy protection on the disc don’t work with DVD-ROM drives. I have the same thing happening with Q-Metric, and I paid a LOT of money for that one back in the day.

Another issue happens if the ROM drive is not the D drive too, sometimes…

Tried the CD rom solution but no go. On Windows 7 64 bit the installer reports that it “will only run from the original CD rom” with both Model E and LM4 original discs. I did use an older CD rom only drive and made sure that the drive letter was “D”…My opinion? The problem lies in what these installers are writing into the registry. Any other ideas are welcome. Thanks to all for the input!

Wow :astonished:
I have never seen that combination not work before - completely out of ideas now.

After much gnashing of teeth (and a little help from google) I have successfully installed Model-E and LM4 on my Windows 7 64 bit machine. Disclaimer: the fix is not for the faint of heart and I take no responsibility for problems that this may cause since it involves creating an entry in the Windows registry which can cause serious problems with your computer. This is what I did:

For Windows 7, use regedit, navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft \Windows\CurrentVersion

Then choose Edit. New String Value. Title it ProductID. In the value field, put the product id
replace the x’s with your WindowsXP product id.

Both products installed perfectly after this tweak. The Model-E made only a buzzing sound at version 1.0 but version 1.1 which is available as an update from Steinberg works fine. So there you have it folks. The original install CDs with Model-E and LM4 want to see a Windows XP product key in the registry. If you still have your original install CDs I can recommend this method of getting your software installed. Cheers!

There is an updated version available that should work right away and does not require the old CD or a previous installation. It is an unsupported release though:

Thats very kind of you guys, Thank you.

Absolutely wonderful. Very cool new gui and funny message when you click on the Steinberg logo. Long live Model-E!

Thanks Steinberg!

The Model-E is 16 part multi timbal and has multiple stereo outputs. :open_mouth: That’s kind of cool even by todays standards.

I just found out about the new version…THANK YOU! THANK YOU! THANK YOU! I’m really pleased to have the old critter back…and just in time for Christmas! Steinberg have come up trumps for me several times recently, including replacing damaged install discs (on dongle protected products, I hasten to add!) and now this.
I might even buy a second hand Houston and see what happens! OK, maybe not…

As a matter of interest, I bought LM4 off ebay the other day, but didn’t have any problems installing it. Rum eh?

Model E has now been re-released as part of free VST Classics 1 package from Steinberg Website. That solved my problem. Thanks everyone for your contribution.