modifying percussion in kit changes rhythm

Hello,
I wrote this rhythm on Tom 2


When I move it to Snare 1 (select, alt + arrow down), the rhythm is changed to this:

why is this happening? I do not want to change the rhythm, just the instrument!
thanks
Florent

When you moved it down, had you selected both the notes and the tuplet?

I’ve tried both, it does not seem to make a difference if the triplet is selected or not

Yeah, this seems like a bug.

OK thanks for confirming.
I’m really having a hard time working with triplets on a drum set track then. I’ve tried moving notes in the Play mode but it does not make any difference.
If someone has suggestions, I’d be happy to hear how people work with percussion and triplets.
thanks
Florent

Some issues here, too -> see https://www.steinberg.net/forums/viewtopic.php?f=246&t=163015

You have to remember that, internally, each percussion instrument has its own stave. A five line Percussion stave in Dorico is a representation of all of these individual single line staves.

What’s happening in this case, is that you’re selecting the notes on the Tom 2 stave, but you’re (inadvertently) selecting a linked triplet number, not the one that’s attached to the Tom 2 stave. The end result of cutting and pasting the notes, without the tuplet number, is exactly the same as the end result when you try and cut and paste tuplets without their bracket/number on regular pitched staves. (Sadly) this is expected behaviour.

You can work around this by having a layout that uses single line staves for Percussion. See below (and note that I’m having to copy and paste - the “move to staff above/below” commands don’t work here):

thanks for the calorification it makes sense
I also have noticed than editing drum set parts tends to be less buggy when displaying the individual parts

Any idea of a shortcut for switching between 5-line staff and individual instruments? It seems like it’s something I’m gonna have to do all the the time…

Seeing as the switch can only be made within Layout Options, a keyboard shortcut can’t even be achieved via scripting. My favoured method is the one I’ve used above - an entirely separate single-line layout, viewed with a vertical split (or even in a separate window).

OK thanks for the tip, I will definitely use in my next piece!
cheers