Mohave - Activating or Deactivating MIDI controller crashes Cubase

Steps to reproduce in Mohave

  1. Start Cubase 9.5, 10, or 10.5
  2. Turn on or off MIDI Keyboard or other Controller (Drum pads etc.)
  3. Instant crash.

This only happens in Cubase on Mohave. Not El Capitan or earlier.
Doesn’t happen with any other program - ie HALion, Sampletank etc.

The only way to avoid crash is to turn on the keyboard before Cubase starts, or after it closes.

Here is one of the crash reports.
C10.5-Keyboard (31.5 KB)


Do you use NI Komplete Kontrol keyboard buy any chance? I have seen exactly the same crash with NI Komplete Kontrol keyboard.

Btw, this particular crash ends up in HALion 6,

No NI. I’m using Yamaha S90es as my main keyboard. Also iRig Keys and Akai MPD drum pads. All produce the same Cubase crash if turned on or off while Cubase is running. HALion doesn’t crash here.


Reported to Steinberg CAN-26889.

Thanks Martin.

Went back and tried trashing preferences again. This time it worked. (Maybe I forgot to remove all previous Cubase version prefs when I trashed them before.) Happy now.

I solved deleting plugins whitelist file from preferences.