Mojave Support on Mac?

So as far as I can see we have a new version of Cubase and the previous version still does not support Mojave on Mac.

I love a new release, but cannot for the life of me find anything about compatibility.

If anyone knows anything please do let me know!


Cheers

DaveP

Go to the Steinberg page, there you can look it up yourself… :unamused:

Cheers - you mean this?

https://helpcenter.steinberg.de/hc/en-us/articles/360000925779-macOS-10-14-Mojave-Steinberg-Product-Compatibility

exactly

Be warned -Sierra & High Sierra only for now folks.

We are in the last phases of testing. There will be more news soon.

Pretty crazy for Cubase to release a new version when we’re still waiting for the go ahead to upgrade to Mojave. Staying with Sierra and 9.5 for now and even that has cpu glitches but that’s about all the glitches I can deal with for now

Please read the announcement for news: https://www.steinberg.net/forums/viewtopic.php?f=34&t=148683