I see that Cubase 10 has been certified for Mac OS Mojave. Does anyone have any experiences, good or bad, of using Mojave? How’s performance?

Thanks, Rich

I loaded Mojave onto a 2018 MacBook Pro and struggled to get it to work with Cubase 9.5. I got it working by removing the Yamaha USB driver, which meant I couldn’t use my UR824.

I loaded Cubase 10 on the same machine and it seems to work well. I tried reloading the Yamaha USB driver just to see if it worked, and lo and behold it did. Early days, but so far Cubase 10 and Mojave are working well for me - much better than 9.5 because of the driver issue.


Working fine here

Works perfectly here.

Thanks for your comments folks. I’m going to give it a go.

Unfortunately my Mojave with Cubase 10 experience hasn’t been as positive.

Using a Roland UA-1010 Octa-Capture interface with the latest Mojave compatible drivers. Late 2013 iMac.
Cubase seems to take quite a bit longer to start.
When I open my default project which has 8 external instruments assigned the project hangs for around 10 seconds at the end of the load.
Then I get no audio input/output for another 10 seconds or so.
For example I can open the project. Activate the metronome, press play and there’s no clicks for around 10 seconds.
Also if I add or remove an external instrument track the audio drops for around 10 seconds.

I’ve reinstalled the Roland drivers. Trashed preferences in Cubase. Created a new default project from scratch but no joy.
Same issue with a fresh install of Mojave and Cubase 10 or an upgrade on my existing High Sierra installation.
Next step is to install it all on my MacBook and see if I get the same issue.

I don’t get this problem with other audio applications such as Adobe Audition with Mojave & the UA-1010 but whenever I open the project in Cubase or modify an external instrument track the audio drops out from the whole system including other applications.

I do Mac support for a living so happy to try out whatever to get this working… waiting to hear back from Steinberg & Roland support. Something somewhere between Cubase / Roland drivers / Mojave just isn’t working for me.
In the meantime I’ve rolled back to High Sierra via Time Machine and it all went back to working properly straight away.