monitoring audio input through plug in

i know this is a tricky feature in WL… and one i hope they make more usable in WL10… (probably my #1 wished-for feature)… but, i’ll get right to my specific situation.

i’m using a new TC Clarity M external meter, really great and nicely featured… and while WL’s input metering is pretty amazing, it’s nice to have an external meter that’s visible at all times, regardless of what program i’m in.

the Clarity M, among other digital and analog connections, can monitor and meter an audio stream with a direct USB connection via a plug in in a DAW. very handy… except in WaveLab where i run into my problem… i need to monitor the INPUT of my record-enabled WaveLab (since i capture from pro tools into WaveLab in my mastering rig), but if i insert the Clarity M plug in in the master section of WL, of course the incoming audio stream doesn’t pass through the master plug ins, so the external meter doesn’t register anything.

i’ve messed around with the AUDIO INPUT ASIO plug, but haven’t had any success… not sure why monitoring through a plug in on input should be so difficult… but it must be.

anyone have any recommendations before i try looking for alternate/analog points to feed the meter from?

thanks
taylor

You mean you have the Audio Input plugin in Slot 1 and the Clarity plugin in Slot 2, Wavelab transport button in “Play”, and you get nothing on the Clarity meters? I agree the Audio input and External Gear plugins setup Is much too difficult, unusual, and limiting compared to other programs, and hope it will be changed, but it should work with that basic setup, afaik.

yes to the plug in chain… no to PLAY… didn’t know i had to play… me try that when i have a break and report back. thanks!

hmmm… no luck… of course, with no file open PLAY isn’t working… and i wouldn’t want to have to play back some random file while i’m recording at the same time (if it could even do that)… so not why you have to play something while you also record…

hmmm…

Oh wow, I didn’t even know this was a thing because I don’t use WaveLab to capture from analog.

I also use the Clarity M plugin (in the playback processing slot) and all the metering DEFINITELY has to be after the analog input and any additional processing inserted after the analog input so that you can meter and hear what’s being captured.

I do hope this area can be improved so WaveLab can be used for play and capture in one project/session without compromise.

Sorry, I forgot about the file, or whether it’s even needed. It won’t play the file. “Play” will just sit there, but it will enable signal to pass through to the following plugins.
https://steinberg.help/wavelab_pro_plug_in_reference/v9.5/en/_shared/topics/plug_ref/master_section_audio_input_setting_up_t.html

If it still doesn’t work, you might try a different plugin instead of Clarity in Slot 2 to see if it’s getting signal. If it is, it might be something about the Clarity plugin in Wavelab or this particular use on Input.

Also, are you putting Clarity M in one of the main plugins slots, or are you using the Playback Processing slots?

I don’t think this will solve anything but I think best practice is to have Clarity M in one of the two Playback Processing slots so that the plugin is not potentially part of any rendering.

@bob99 thanks, it works!! great, and not so difficult as i imagined…

now, i wonder if by playing with the input/ouput ASIO plug in assignments (in the audio preference) i can change WHERE the meter is seeing the audio… as in pre or post-capture…

i would hope the plug in doesn’t alter the audio in any way, but it’s a good thing to consider.

unfortunately, it doesn’t seem like you can put any plug ins in the PLAYBACK spot… the only choice for me among all of my plug ins is the steinberg “encoder checker”

is there a way to put other plugs there?

Right. I’d like to think it doesn’t affect the audio too but since I tend to error on the side of paranoid, I keep the Clarity M plugin in the Playback Processing slot in WaveLab which is excluded from audio rendering, just be sure. And when I’m in REAPER, I keep the Clarity M in the REAPER equivalent of the Playback Processing slot.


If you go into the Preferences/Plugins area you can check a box that will allow Clarity M (and any other plugin you’d like) to be inserted into the Playback Processing slot. By default, only Encoder Checker is assigned there but you can allow any plugin to be used there.

oh, brilliant! that would definitely make me more comfortable as well…

however, i can’t seem to get it to work… i’ve checked the appropriate box (both vat and vst3, together and on their own) and restarted WL multiple times, but the plug doesn’t appear in the playback menu…

see screen shot:

I’m not sure because I pretty much always keep the master section hidden and this plugin just lives there and I never have to change anything in the master section. So it’s been kind of a “set it and forget it” thing.

Anyway, let me know if my two attached screen shots help. It looks like you may not have the right boxes selected.


yeah, i had the wrong boxes checked… thanks!

works well… to a point… unfortunately when i actually hit RECORD in the record window to print my master i get a crazy feedback loop happening. likely has to do with the ASIO input/output assignments… since they conflict/are the same as my main capture/playback assignments.

i’ll have to see if there’s a solution

edit: this is what’s happening, feedback-wise

PLAYING FROM PRO TOOLS >
INPUT AND CLARITY PLUG IN WAVELAB

audio file open in WL, no record dialogue: hit PLAY, get feedback

audio file open in WL, record window active, hit play, NO feedback

audio file open in WL, record window active, hit play, and RECORD: feedback








Interesting findings. I didn’t think moving the Clarity M would solve your problem fully but it’s interesting that the results changed.

I wish I could help more but there are many reasons other than this why I do the analog gear processing in another app. It’s just not worth the current headaches/compromises/workarounds as you have to do it now in WaveLab.

there’s got to be a way to have the plug in (clarity in my case) see the input without feeding the audio out back into the recording input…

between WL’s ASIO routings, any internal routing possibilities on the UAD Apollo 16… just seems weird that if you ever want to record an external signal through a plug in in WL you get feedback (so what’s the point?)… maybe i have my ASIO audio settings wrong… but the audio only seems to go to the plug ins if i have the ASIO setting in and outs the same as my playback and capture in and outs … wherein lies the feedback loop.

i read something in the manual about using the RENDER command instead of opening the recording dialogue and “recording” when capturing incoming audio through a plug in… ?? is this what you’re supposed to do?

Hi!

Can you show your Input/Output settings under Audio Device
or if a software mixer is included in the chain “a picture is fine”
it should´t be any feedback right ?

regards S-EH

here are screenshots of my PLAYBACK, RECORDING and ASIO routings in wavelab

i use the Universal Audio Console for some routing, but nothing besides default stuff, mostly. i keep certain channels muted to prevent feedback loops.

a very brief rundown: playback comes from pro tools out the Apollo AES, into a cranesong HEDD, through my analog chain, back into the HEDD, into the apollo and captured in WL.