Monitoring issues in Cubase Studio 5

Hi all…very vexing problem here, but I’m sure you’ve seen it before.

I’m using Cubase Studio 5 with Windows 8 (I know, I know…not supported, upgrade etc, but I hope that’s not the problem!) with a Zoom R8 interface (which finally got Windows 8 drivers). The setup seems to work OK in general, but when I record my guitar track, I use the mix knob on the R8 to get a reasonable monitor mix, and I’ve turned off the “Monitor Enable” button on the track so I monitor directly from the R8. At least that’s the intention, and it seems fine when I’m playing to the other tracks.

However, after I record the track and play it back, I get that awful echo, presumably due to latency issues, like you would hear when you’re not doing direct monitoring.

I’m wondering which setting needs to be turned off (or on) to avoid this. I’ve wracked my brain on this, and nothing I look for inside Cubase seems to work.

Any ideas?

Thanks in advance!