Monitoring Latency issue in C7 with fresh setup

I’ve recently rebuilt my music computer and additionally got a new audio interface, as my long-serving MOTU 828 decided to give up.
Now, I’ve got everything pretty much set up again with Cubase 7, however I’m having a small issue with monitoring what I’m trying to record.
Basically (as an example) what I’m trying to do is record my electronic drum kit and listen to what I’m playing while monitoring via cubase, but what I’m getting it a certain amount of delay in that monitoring signal, to the point where it’s a bit of a flam/slapback and offputting.
So for either of: playing a test midi part and listening to the output of the drum module vs what’s coming out via cubase in headphones, or sitting playing at the kit and listening to the same (audio) output via cubase on headphones has a delay.
Recordings are fine (in time) and I don’t think it’s any kind of midi delay as it really is just the audio path through cubase vs direct that’s the issue.

The shiny new audio box is an SSL MadiExteme PCI-E card with a Madi-AX 24/24 i/o (+24 ADAT i/o).
This is set to 64 samples (which is the least the control panel will accept), which gives me in cubase 1.610/3.061 ms latency, which you’d think would be unnoticable! Except it’s not.
The ‘direct monitoring’ option isn’t available, and anyway I’ve got all the in/outs wired to different things.

What’s slightly weird is that an electric guitar (or bass) plugged into the same kit doesn’t have the same delay and is actually rather playable.
There aren’t yet any plugins on these tracks, so I’m at a bit of a loss to explain this.
Any ideas?..

(I’m actually supposed to be having a band over this weekend for recording! eeek!)

Try 128 samples and see what happens there. Does the latency increase or stay the same?
Cordless digital phones? You can get latency on those.

Since you said it feels like a flam/slapback, it might be a MIDI issue rather than audio.
Make sure the channel only gets ONE MIDI input rather than a duplicate, you might be getting them twice, in delay.
In the MIDI setup, make sure you don’t have duplicates activated.