Monitoring midi while recording

With my Yamaha keyboard I can record and playback midi instruments normally. With audio files I can hear while recording with either direct monitoring of my interface or through Cubase.

In Halion Sonic, for example, I can play its built-in keyboard and hear the sounds before recording, but I cannot monitor the notes played on the Yamaha keyboard until after recording. The same is true of the alt-K feature activated on the transport bar. I have read here and made sure that record enable allows midi thru is checked. All record filters are unchecked. I have never had this problem with Cubase VST5 or SX3. I am using Windows 10.
What next?

Not sure that I got exactly your issue but, if Halion SE3 is involved, it works here both with my keyboard and with the On-screen keyboard (alt+K), here. So, how are you using HSE3 ? In an instrument track directly or via a MIDI one, routed to Halion SE3 set in another instrument track or as an instrument rack ? In all cases, double check the following :

  • that indeed the MIDI>MIDI Thru Active setting is checked in the Preferences,
  • Also in the Preferences, the way the VST > Auto Monitoring option is set : I generally use the Tapemachine Style option,
  • the MIDI channel in the track inspector is set to trigger the corresponding program slot in HSE3,
  • the output routing is coherent, if Halion SE3 isn’t used in an instrument track,
  • the Monitor button is activated in the inspector/track header, if the Record one isn’t.

FWIW, I never use the Direct Monitoring : it has always brought more issues than solutions, but I have the chance to have an interface which allows me to do so, I admit…

Thanks for the checklist. I closed out Cubase 8.5. Started Cubase SX3 to confirm that VST instruments were monitoring fine there, as my problem was with ANY VST instrument I had tried in 8.5.

Earlier I was poking around in the Yamaha keyboard settings to see if there was anything there, so when I went back to 8.5 I could not even record. Before I was getting MIDI signals for certain and recording but no monitoring. This time the Alt+K keyboard was working. Then I restarted the Yamaha and now I am able to get monitoring signals.

I had become accustomed to this glitchy behavior in earlier versions of Cubase. I hope this will not be the case in 8.5 which I am just learning to use.

I had done all these things before without progress. Restarted everything. Ony this time I disconnected the laptop and reconnected it. I left it alone for several hours and came back after I saw your post. Who knows what made the difference?

So, unless I haven’t got it, the issue is solved ? I hope so, but absolutely unable to give you a rational explanation, if it’s the case : DAW related things often don’t behave as one could expect… :grin:

1 Like

Solved, I am not sure. It happened again today. I closed out the program and turned off the keyboard. Restarted everything and now things are fine. It might have something to do with changing the voices or settings on the keyboard. If I find out the specifics I will post them here.

1 Like