monitoring with rendering with external gear

Does wl8 finally support audio monitoring during rendering with external gear in the chain?

There is no explicit support for this, but you can use the recorder in mode “Record what is playback”, to render. There was a bug in 7.x that caused the start of the audio to be missing in the resulting file, but this has been fixed in 8.0

Come on PG… this is something that a lot of people have been asking for since version 6!
The problem that you fixed is something that I have been saying since i got the beta version of 7.2 from you and you sayed the problem was there? That is why still stick to 7.1 because that doesn’t have that problem.
I’m REALLY annoyed now PG. Wavelab is a great program but this is really so unprofessional…

I meant, I solved in 8 something that was not solved in 7.2.1

On 15-6-2011 I was betatesting 7.11 for you and I already told you exactly that problem which wasn’t there in 7.1. (that is why I still use 7.1)
I still have all those emails if you want to read them but it was a known problem which you said it wasn’t there in the first place… :frowning:
Rendering without hearing what is going on is a no go for a professional mastering-engineer, this has been discussed a lot of times before, even with v6. I really don’t understand why there is still no functionality to listen to the rendering in realtime. The only workaround that everyone is using is indeed re-recording what is played back. But then you will have this problem at the start, but also at the end of the file because it’s stops with recording too soon.

It’s OK that you finally solved that problem, but it should have been solved a LOT earlier, it was simply a known issue which I brought up almost 2 years ago.

A small copy/paste from the mail I send you about testing 7.11 on 15-6-2011.

_>

OK, external gear:
When i playback something with the external gear pluginn in line together with some other pluginns (psp neon >external gear > ozone4>fabfilter pro-l) after the first couple of milliseconds there is some strange audio skipping (check the mp3 attached). Even when i insert a silence at the start of 100ms it still misses the first attack of for example a bassdrum. It doesn’t matter if I set the latency in the external gear to auto or a longer manual timing. In the mp3 i have 50ms of silence in front and the first 2 times when i start there is no processing, the 2x with processing set to auto and then 2x processing set to something like 600ms in the externa gear plug and after that 2x without processing. With 7.1 i never had this problem with the exact same chain._

And a copy/paste from a post on 20-12-2011 (http://www.steinberg.net/forum/viewtopic.php?f=47&t=16662&hilit=external+gear)

Re: external gear with 7.2 not working the way it should
by da goose » 20 Dec 2011 17:42

PG wrote:
You should try the Silence plugin, to insert silence at the start and end, and cut exactly the extra audio afterwards.

I know that will work but that is a workaround like i described earlier.
Could you please review the problem? that will help a lot of people because, like i said before, a masteringengineer wants to hear what is going on in realtime. Specially when you have an attending client.
www.mastering-online.nl

da goose
Junior Member

Posts: 130
Joined: 26 Dec 2010 14:35
Top
Re: external gear with 7.2 not working the way it should
by PG » 20 Dec 2011 20:26

I guess a function “audition while rendering to file” would be more appropriate than the workaround you do, with the recorder.
Re: external gear with 7.2 not working the way it should
by PG » 25 Dec 2011 11:34

PG? any idea when this is going to be implemented?


Next big version (8.0)

This is very ‘indispensable’ for mastering…

PG?

What I tried to explain, is that the bug that caused you to return to 7.1, has been fixed in 8.0, hence you have a solution to monitor what you render, through the Record dialog.
A specialized function to monitor what you render to file, has not been implemented. I discussed this topic with some WaveLab Mastering users, who did not think it was important enough. Because if you want to really check your mastered files, you have to check them after they have been written, and not before.

I understand it has been fixed now, that is not the point. The point is that 2 (!) years ago, with a betaversion i already said that this problem was there and you said it WASN’T there but now all of a sudden you say it is… V8 comes out and all of a sudden you say there was a problem and you fixed it. :confused:

You literary said that it was going to be in v8 and even ‘came up’ with the idea yourself (see your own quotes above copy/pasted from an old topic) and now you say that masteringengineers don’t need it?
I really don’t get it… What you describe is a no go way for mastering-engineers, iI copy/paste my own daily, profesional experience from the old topic again to point out why.

Just to give you an idea:

a track, 7 minutes long, all settings done > time to render.
7 minutes bouncing the way i work with re-recording/hearing what is going on.
Glitch (which can always happen, we are working with computers here) after let’s say 3 minutes, heard in real-time.
Press stop > delete file > re-record. All done in 10 minutes.

same 7 minute track rendering without hearing what is going on.
Glitch after 3 minutes > rendering done after 7 minutes (you don’t know that the glitch is there) > listen again from start to see if there are any glitches > find out there is a glitch after 3 minutes > stop, delete file> re-render again. (10 minutes lost already)
Re-render > 7 minutes rendering and then listening from the start again = 7 minutes makes a total of 14 minutes + the 10 minutes from before. All done in 24 minutes!

If this was an un-attended session it will cost me a LOT of time in total = money while with attending customers it’s even worse because who is going to pay for the extra time? the customer or do i have to pay for it myself and how professional do you think this will look?

I am MORE then let down by steinberg about this especially since this option was asked for since V6!
To me steinberg really doesn’t take their loyal PAYING customers seriously here… :cry:

There is an existing solution for what you are requesting for. You have to use the Record dialog and activate “Record what is played back”, that’s not a big waste of time. Even if, I agree, this could be done in a slicker way.

never mind… it looks like you are still reading only 25% of the story…

Don’t get me wrong, I like wavelab, I use it everyday. I also really appreciate all of the work and feedback you give here on the forum.

I have been using WL since v4 IIRC and i have been using the record what is played back since V6 so I exactly know what it does because I work that way all the time.
The reason it annoys me is that I pointed you to the bug 2 years ago and so i’m dealing with it every day.
There are some nice additions to WL8 that are indeed a reason for me to upgrade, also the external gear bug that has been fixed is a good thing and the reason to get it. But still, it’s a workaround that has been going on since V6 while V8 should have been the version where it finally was taken care of but it’s not. :cry:

Dear Da Goose,

This is exactly what I do with Wavelab 7! I don’t record my analog chain, I render it and while doing that I hear it play back. I’ve stated this once for your consideration in another thread wherein you had voiced the same concern. I don’t know what’s wrong with your monitoring setup but you might want to give it some extra scrutiny.

Rendering with external gear is done in real-time which is in and of itself a form of playback. You simply have to get a copy of that playback in your monitoring. If, during rendering, Wavelab does in fact feed a signal to your external gear then that is it! A failure to hear it is a failure of one’s monitoring system not of Wavelab.

I agree partly on this. Sure i can listen to the input of the external gear in realtime if i want to, it’s anlog audio and so can be played back. But there are also plugins AFTER the analog chain and there is simply no way you can hear those back without re-recording the way i work now, no matter what.

Thanks for your clarification, I now see your scenario and the point in the signal flow at which you want to monitor the sound. I cannot comment any further at this moment as I don’t work the way you do. I like to have the output of the analog chain recorded as a separate file before applying any final digital processing so that the latter can be applied to the aforementioned file in a non-destructive way. Still, I’ll make an effort to reproduce the problem you’re addressing if not to solve it then just to gain a personal experience of it.

In the meantime, good luck with your work, let not shortcomings of this nature upset your well-being to much.

While doing the rendering (re-recoding in my case) i also listen differently then during the mastering itself. You will listen more passively and for some reason, because of this, you could suddenly hear/notice things that you didn’t hear during the mastering itself because you simply listen differently. It’s hard to explain, but it really works well and I heard things that way that I would never have noticed otherwise, or at least not as easy.
I also make an analog bounce first a lot of times and apply the pluginns later BTW, but not always and then I simply need it.

I’m already ‘calmed down’ on this topic a bit, especially since the problem with the stop and end glitches is solved now. :smiley: But still i’d really like to see this function to be implemented in, let’s say 8.02. :sunglasses:

Here’s my solution. I use 1 instance of WL with the raw files in an audio montage. Then, I open a second instance in audio file mode. Put the audio input plugin first in the master section, then any final plugs (limiting, etc). Press space bar to monitor. (obviously you need to set up your own monitoring setup for this to work.) I’ve been doing this for 6 years now. I’ve never used the external gear insert, and don’t see the need to. My setup is the classic Pitch/catch just using 1 PC. Works great. When you’re ready to record hit the render button to arm and name the file. Monitor the capture in real time on your console. There are a few additional command line you need to put into one of the startup files (pg…can you remember this?) to allow WL7-8 to open 2 instances at once.

Pete Lyman
Infrasonic Mastering

If that is your question, opening a second instance of wavelab is possible in 8 as in 7, with a non official switch.

I agree with Da Goose. Moreover I would have liked to see the external gear insert option in the clip plugins and also the possibility to “bounce in place” with real time monitoring. That would speed up the workflow!

From what I see on this forum this will not happen anytime soon…