mono file is playing in one speaker only - sample rate

I just had the weirdest bug.

Had two mono files loaded with different sample rates 44 and 48.

One playing fine - when trying to play the other (48) it only played on the left channel.

Processed resample to 44 - still only in one side.

Saved the file and reopened wavelab - fixed. Something’s wrong?

Latest update.

just happened again . same story switching between files w different sample rates

that is fixed in the next update patch.

OK and when is that coming? This is quote annoying :slight_smile:


I feel as if we are all being subjected to the old Chinese Water Torture (think drip, drip, drip on your forehead) waiting for the next update that will “cure” or “fix” some new/old problems that crop up. It is beginning to look like this is going to be a long process. FWIW. :frowning:

No disrespect for PG but this all should have been “FIXED” before the release of WL 10. I guess the suggestions by others about better BETA testing should be looked at rather closely. Maybe do more public BETA testing before the release with a time limited public beta before the actual update is put out. I am a BETA tester for a couple of software developers and I can truthfully say these companies do NOT have the massive amounts of problems that the current version or WL has and much of that is because of the way they do their BETA testing. :bulb:

Well yeah . I understand bugs can be missed during testing but this one should be fixed as a hotfix. It is strange it wasn’t caught in internal testing what I caught the first time I used this new version.

Happy about the reduced render time with UAD plugins though and as always - thanks to PG and other Steinberg employees for staying updated and responding in here. Something you don’t see too many places.

This mono file symptom is fixed in upcoming 10.0.30.

Happy about the reduced render time with UAD plugins though

Yes, and I also reported this to UAD, because the real problem is on the UAD side (though it could be a constraint in their driver). WaveLab is just using some special setting to avoid the problem.

anybody found a workaround for this bug?

Same problem here, and I’ve wasted my whole weekend because I’m new to WaveLab. I found a solution: Restart WaveLab, open and play a stereo file and then record / edit / play your mono file - it should play on both channels (you have to do this every time you start WaveLab). If you play at first a mono file and then a stereo file, the stereo file will be also played only at the left channel. It seems, that the audio engine has to be initialized with stereo content to work flawessly. Weird.

super nasty - luckily a fix is due march