Mono->Stereo External FX

Forgive me if this is common knowledge, I’m fairly new to Cubase and couldn’t find an answer elsewhere.

I have a hardware guitar effects box that has a mono input and a stereo output. I’ve added it in the External FX section in VST connections. I now want to be able to use it as an insert on a mono audio track (which is being mixed into a stereo output).

When I opened the Insert Routing section in the VST Audio Channel Settings for the mono track, I noticed that there are two channels available to the inserts. I added the (already defined) external effect as a VST insert and adjusted the send/return levels (my effects box showed it was getting sufficient input, and my audio interface showed good levels coming back in on both channels).

The first thing I noticed was that there was that my left channel was coming through wet as expected, while my right channel was dry/unaffected. After reading about the inserts routing a bit, i realized that the default for a mono->stereo insert is to pass one channel through dry. I fixed this by disconnecting the right (dry) channel in the inserts routing pane. Unfortunately, although this made the audio come through as desired, it was only on the left channel with the right channel silent.

I am assuming that the L & R outputs from a mono channel to a stereo output are identical at the start of the insert chain. Therefore, it should make no difference which “wire” in the inserts routing that I input to my external FX box. However, my theory is that when I cut the connection of the “dry” output (not being sent to the fx box), cubase assumes I do not want any of the track output to contribute to the corresponding L/R channel master stereo output. Since, I am generating a stereo sound from a mono signal, this is not the case. I see that my FX box is returning both channels and, according to the inserts routing, both of those channels should be coming back through Cubase in the insert chain.

Has anyone else experienced this? Is there an elegant solution or option I can disable to get both outputs from my external FX box?

Try using a stereo channel, create a stereo channel and drag the guitar track onto it.

If I may suggest something. Don’t do this as an insert, but instead as a MonoSend/StereoReturn path.

The idea is to route one of your Sends from Audio (or VSTi) tracks to the outboard box’s mono input and return the box’s stereo output back into Cubase.

You need to do two things to make this work.

First, you need to set up a Mono out/Stereo in EFX Track. Go to the VST Connections menu and do this:
screenshot_03.jpg
Then, open the Efx Return’s Channel editor and do this:
screenshot_04.jpg
This last bit guarantees a true stereo return minus any dry input signal.
As for elegance…it means you can send the audio from any number of tracks simultaneously to the outboard box and mix in the result with only a single EFX channel. If you want “Nothing but Effects Box” and none of the original track’s signal, simply make the source track’s Send: Pre and pull down the source channel fader.

I do this all the time and it works a charm.

Thanks for the replies. Before seeing them posted, I ran into some 64/32 bit (vst) issues and decided to uninstall my 64 bit version and jump down to 32 bit. The really weird thing is that the strange behavior I was experiencing before had vanished after the reinstall. I even came back in here to replicate my own steps I had outlined, but everything worked fine.

Just in case, I tried the methods you guys mentioned.

To try this out, I recorded my dx27 on a mono channel and then dragged the recording over to a stereo channel with the external FX as an insert. Although i still had a disable the dry channel being passed through, it worked perfectly. I had no idea you could push mono parts over to a stereo track so easily either!


I also tried this approach, and it works as well. Thanks! Is there a fairly simple way to freeze/record the return audio from the send effect?