Montage "Mismatched Sample Rates" SRC Function

Using the Montage “Mismatched Sample Rates” SRC Function (right-click, insert a file of a different rate), I’m getting a file save error if the source files are dual-mono, inserting into a Stereo track. On Windows, Wavelab seems to be attempting to save with the name including the vertical pipe, which I guess is illegal on Windows. So the file save fails.

Untitled-L | Untitled-R-44100.wav. An Error Occurred. This File Could Not Be Created.

Could this be looked at and fixed if a bug?

I really like the convenience of this function, doing the SRC right in the montage, but would also like to ask if 2 things could be added as a feature request: option to include the Peak Master in the conversion (after Crystal), and option to save to the source soundfile folder. (which in my case is sometimes not the montage folder, and I don’t want in the Data folder). Thanks!

Sounds like a bug to fix, indeed.