More annoying tie problems

So I work out what rhythmic notation I want and add the tie which completely re-figures the notation I want, in this case adding a dotted note. Why is it doing this? Adding ties shouldn’t affect the rhythmic notation at all. Even using the force duration key doesn’t always do anything. To me this should be considered a bug.
tieprob1
tieprob2

Dorico thinks of tied notes as single durations. This particular setting governs this particular note grouping.

If you don’t like it, change it. Or if you don’t like it in this one specific instance, select the three notes (as in your first image), then hit O to turn on Force Duration for all three notes, then hit T to tie.

If you’re hitting O to turn on Force Duration after you’ve tied stuff together, then you need to know that doing that locks the existing note values - it’s not supposed to mind-read the groupings that you want to change to.

When tie-ing notes with Force Duration, it’s often best to work left-to-right: set Force Duration on all notes ideally, then tie the leftmost note to the next note to the right, and so on. If you set Force Duration on the 2nd note, then tie a preceding note to it, you lose the settings because the 2nd note gets “eaten” by the first: it’s the first note that then dictates settings for the overall note (because Dorico treats tied notes as a single note “event”, as Leo said above).

You can also specify note and beam grouping according to the meter.

2 Likes

Lillie,

I still find the terms Force Duration and Lock Duration very confusing. What is doing the forcing and what exactly is locked?

Often I find myself randomly cutting ties, selecting notes and forcing/locking until I arrive at what I want, with absolutely no understanding as to how I got there! I’m sorry I can’t articulate the problem more clearly.

In Force Duration, you are “forcing” Dorico to display exactly the duration you entered, and not re-beam or re-bar it according to the meter.

In Lock Duration, you are copying existing durations into a sequence, and “locking” them so, although you are inputting new pitches, the durations are locked and won’t change.

I can understand how the OP’s example would seem like “locking” duration. But it’s Force Duration, because you don’t want Dorico to “fix” the note values, you want them to remain displayed exactly as they were before they were tied.

If you’re finding that there are many notes you have to use Force Duration on, it’s best to adjust the various note groupings in Notation Options. Finding the one which automatically corrects to exactly what you want displayed solves many problems at once. (And I speak from much experience in searching/learning about this.) :wink:

MOST of the time, adjusting the Note Grouping options will get you 90% of the way. There maybe some special instances in which you’ll need to use Force Duration - burit should be rare. There are some issues with some meters which need more options (2/2 is one of them).

1 Like

Thanks for the replies - will require further looking into.

Thanks, Dan.
I now realise that I need to use Force Duration far more often during note input!

Well, perhaps. The intention is that Force Duration should be the exception, not the norm. If you find yourself using it a lot, it may be there’s a notation option that needs to be changed.

I appreciate that, but for now I suspect my needs are atypical. Much of my current work involves rhythmic patterns that do not fall neatly onto beats or bars. I’ve experimented with many of the Notation Options, but none has avoided a lot of post-entry editing (hence my earlier frustration!).

Notwithstanding the intent of the creators, your explanation has increased my understanding and made my life easier. So, once again, thank you.

I used to do that for non-conventional rhythms (back when I was still hand-writing scores and parts), but I later learned that my notation was confusing musicians when we had little rehearsal time and that I got more reliable results putting those rhythms into standard notation.

To each his own.

I have the same problem