More control over staff visibility

Hello, if I don’t want to activate automatic hiding of empty staves in the Layout Option and instead use manual staff visibility I can possibly run into the following problem:
From some point in the Layout I hide f.e. an empty Flute stave - without noticing that somewhere (400 bars later) there are still 8 Flute bars to be played. They will vanish from my layout without me noticing it. I would send out the music, and in the first rehearsal there will be a silent moment…
My request would be, if I activate Manual Staff Visibility to hide a staff, to have either a warning, that there is still music at a later point - or the option to only hide the stave until the next musical event.


Good idea (but I’ve found that hiding staffs in Galley view doesn’t work, only in Page view)

Rob, yes, layout is always Page View (by definition).

Hiding staves with music has its uses, too; but perhaps a warning would be nice.

It’s always best to work backwards, adding a ‘reset’ first, and then hide staves once you’ve got your ‘backstop’.


Yes, working backwards is a safe workaround.
In a way this is against the necessary workflow to adjust a layout from the front onwards, resulting in the necessity to jump back and forth…

Another option would be to set Layout Options to automatically hide every empty staff, and then manually show them if required.

I tend to be very conservative with staff changes. Frequent changes can be confusing. I always ask myself “is this actually saving any paper?”

1 Like

For me automatic hiding does not always work reliable, especially when it comes to Divisi staves.
At the same time when preparing parts, space always seems a big issue.
To get sensible page turns and keeping the staff size at a comfortable size basically the DINA4 paper size does not work.
Parts should be easily readable even under poor lighting conditions (opera pit, sometimes with dimmed lights, shared desks). I have not found a practical solution for this.

What’s the problem with divisi? A quick test shows that they don’t hide, unless you turn on ‘hide individual staves of multi-staff instruments’.

In any case, I would expect both divisi staves to show when one is empty, so that it’s clear that the 2nds are tacet, and not unison with the 1sts.

Ben, I have more complex parts. It is a combination of three instruments, which I all combine into one part, some bits of them I have to hide. It is a part for different players - into which I combine violin-, flute- and oboe staves, some of them are divisi over a couple of bars. Somehow I have not managed to set it up to work automatically. I have violin players, players who play oboe and flute and players who only play flute and players who only play oboe. They will all get this combined part.

I would also like to see a way to only hide staves with no music in them and it was a bit of a shock to me when it was hiding staves that had music on them. One way would be to only hide selected (i.e. highlighted) bars but I would suspect most people would prefer staves with music on them always be shown by default.

That’s what the options on the Vertical Spacing page of Layout Options are for.

1 Like