More puzzling audio problems

@Ulf . Please help if you can! Issue 1 has been ongoing for a while. Issue 2 has arrived today.

  1. Every time I load a project, the VSTs appear to load (to green arrow stage) but playback is silent. However, at some random time later, playback wakes up and behaves normally (I have done nothing meantime except make a few notational entries and perhaps gone off to make coffee). During a session, if I change a VST, once again I get silence (until my caffeine intake is topped up)… Sometimes it is so long, that I lose patience and shut things down. This has been an issue for quite a while, and the behaviour has not changed with the latest upgrade.
  2. Today (and this is not reliably reproduceable, but it did occur a number of times), even having waited… and things were working OK… if I made a single edit to notes in player2, only the top VST (of 2) would play. The 2nd would show a brief midi blip when P or spacebar pressed, but no notes appeared to be sent and sounds emerged. It was the same result if I changed the second VST to an alternative. This has only manifested on one project so far - the other projects today all used a single VST.

Here’s a cutdown of that file (but the problem does not appear to have carried across. I am unable to post the full original)
VST problem cutdown.dorico (2.5 MB)

Here are the diagnostics from the last time I had both the problems. Dorico Diagnostics (2.4 MB)

I’m on Windows 10, using FlexASIO. The only other audio program running is Vivaldi browser (streaming radio and YouTube).

EDIT: Damnation - it’s just done it again. All I did was delete a hairpin (in the top part), and the piano part refuses to playback.

@Janus I downloaded your minimal working example. But it uses Kontakt instruments I do not have. Hard to know how to help.

What is Aria Player? I don’t have this.

What version of Kontakt do you have? Is there a remote possibility of some unhappiness between Kontakt and Aria Player and FlexASIO?

Curiously, when playing anyway, without the instruments, just to see I hear periodic pops of noise, which I would not expect. I wonder what that may be?

I’ll try it with some basic Kontakt instruments.

Thanks Andro.

Aria (from Plogue Technologies) hosts Garritan Personal Orchestra, though my piano problem started when I was using Pianoteq (both v7 and v8 failed). Aria is a great VST that allows microtuning.

This file uses Kontakt6 (though I have 7, I’ve not updated my playback template). I’ve mixed Aria and Kontakt and Pianoteq before, without problem.

You get pops of noise? Interesting. Perhaps that relates my misfiring VST? (Anyway, it’s way beyond my competence level to troubleshoot)

Totally OT: I’ve just spent the past couple of hours listening (twice) to a fabulous broadcast performance of Mahler 2. BBC Radio 3 (Shenzhen Symphony Orchestra under Daye Lin) - I was completely hooked. (If you can access it, do a spinal tap and amp it up to 11!)

I’m not sure exactly what, but if you look at the application.log file in the Diagnostics you posted, something happened here:

I’m not sure what plugin that was, but clearly when trying to load it, it entered this “overloadDetected” state that lasted for almost 18 seconds. Obviously Ulf should be able to make more sense of this than I can. If you search of “overloadDetected” it appears several times in that log file.

Hi @Janus,
very interesting issue that you have. This is something I have not heard of before. I will take a look at the diagnostics and come back asap.

Thanks Fred,
Overload? It’s just two VSTs (a Cremona Cello and a Pianoteq Piano). Nothing outrageous!

1 Like

Yeah, I would think 2 VSTs wouldn’t be very system intensive at all. I remember there was an issue with FlexASIO a year or so ago where Dorico would only load it at 44.1kHz regardless of what you specified. Perhaps that got cleared up, but just to confirm, everything on your system is at 44.1, right? (Since that’s what loaded in your log file) I need 48kHz for Pro Tools recording, so I think back then is when I gave up and just started using the Voicemeeter Virtual ASIO driver with Dorico. Just making sure a sample rate conflict couldn’t be causing an issue. Also, what do you have in your FlexASIO config file? I’ve now forgotten what he said, but Ulf did recommend certain backend settings with that file to make sure FlexASIO worked well with Dorico.

Hi @Janus,
indeed there are plenty of those overload alerts in the log files, also especially around the time when you first start the playback. Where does the message come from? It’s from the audio engine, when it detects that it has not enough time to fully calculate the necessary audio buffers in due time in order to achieve a steady, continuous audio stream.
The difficult part is now to find out, why this is happening, because there are potentially several reasons that can cause this. First of all it could be a driver or audio device issue.
You use FlexASIO. From the logs I see that there is also a Soundblaster ASIO driver around. Have you tried that one instead and how is that one performing?
I also assume that you use FlexASIO in conjunction with the Soundblaster device, is that correct? Of course the generic drivers work with virtually any audio device, but because they are generic, they can’t take advantage of special features of the audio device. Dedicated ASIO drivers on the other hand should be able to deliver better performance than generic ones. That’s why I wonder you don’t use the Soundblaster ASIO driver.
On the other hand, if you use FlexASIO make sure that you configure it to use WASAPI, the most modern interface into the Windows audio system.
So I’d say, first try with the drivers and see if that may makes a difference. If not we have to take a look at other things.

@Ulf . The SoundBlaster ASIO driver does not work well. I cannot use it to get simultaneous audio across Dorico and other apps (I’ve been using Creative soundcards for many years. I’ve found their hardware excellent, but their drivers always have problems!). Also, even running just Dorico with a simple VST rack, I get pops and glitches (irrespective of buffer settings). Similarly with the Generic ASIO driver.

The only one that works (for me) is FlexASIO (and then only by using Windows MME - NOT Wasapi. Wasapi appears to hijack the exclusive control rule irrespective of any setting I can find to contradict this).

I have managed to get a workable version of the file that behaved strangely when modifying dynamics (a simple xml export-import removed any connection to the VSTs) - but I am reluctant to apply a template other than the HSSE template until the work is done.

I have a suspicion the underlying problems might be Kontakt related… no proof, perhaps just paranoia?

@Janus these things always smell to me like ASIO issues. In the interests of scientifically changing single variables, could you try ASIO4ALL?

Now fully supports Windows 11 - but I know you are on Windows 10 currently.

I have no problems with Kontakt 6 in Dorico 4.x.

{I’m not recommending it, just a test. If it works, then the issue lies with FlexASIO.]

What Creative cards are you using? Aren’t they a bit dated? {Just askin’!]

Hi @Janus,
Andro is quite right, it is also worth trying ASIO4All and see how that goes.

But I have also one more suggestion. Try FlexASIO with WASAPI once more. You know, FlexASIO does not have a driver control panel and instead you have to configure it via the FlexASIO.toml file which is found in your home directory (C:/Users/{your-name}). There is an option to switch off exclusive mode. Here is how my FlexASIO.toml looks like:

backend = "Windows WASAPI"
bufferSizeSamples = 560

device = "Mikrofonarray (Intel® Smart Sound Technologie für digitale Mikrofone)"
wasapiExclusiveMode = false
wasapiAutoConvert = true

device = "Lautsprecher (Realtek(R) Audio)"
wasapiExclusiveMode = false
wasapiAutoConvert = true

(I’ve been using Creative soundcards for many years. I’ve found their hardware excellent, but their drivers always have problems!).

I find this an interesting statement. What good is excellent hardware if the drivers are poor? How do you take advantage of the excellent hardware if not by way of the drivers?


FWIW, I’m using a Behringher USB interface and ASIO 4 All with Dorico (on Windows 10) and haven’t had any issues.

@ulf. That worked! The critical setting appears to be setting wasapiAutoConvert = true in addition to the wasapiExclusiveMode = false. Previously I had been focused only on the exclusivity issue, which seemed rational as different apps were taking exclusive control of audio. I have absolutely no idea what AutoConvert is converting, but applying it seems to have fixed things… for now

@Andro: No I could not get Asio4all to work. It was OK running Dorico on its own, but I had the same problems running (eg) YouTube in parallel.

Finally, the peculiar behaviour of the file that lost playback when changing a dynamic, was solved(?) by doing an xml export and re-importing. (That remains a mystery)

Thanks as ever for all your help.

1 Like

Hi @Janus , I’m glad to hear that it is solved for you. If I’m not mistaken, I think the autoConvert is for automatic sample rate conversion. This allows the application running with a sample rate other than what the physical audio device is currently set up to. The driver then does the appropriate sample rate conversion.
So in the end I guess you could have solved the issue also by matching Dorico’s sample rate with that of the audio device. But you have it working now and can’t be bothered any more, I guess…

Thanks for the explanation. I’m an engineer, so it will always bother me. But, yes, I’ll happily plough ahead until it happens again… (lifelong learning).

1 Like