More Ruler / Grid Divisions?

Hi

Other than zooming in horizontally, is there any way of setting the ruler (and/or the grid) in the Project Window to show more divisions - ie. bar/beat marker lines?

At the zoom level I typically work at, the ruler only shows divisions every two bars, which is making it a little fiddly to drag and copy things quickly. There’s plenty of space to at least show small dividing lines every bar - can this perhaps be setup in a menu or option page I’ve missed?

Thanks for any help.

Jules

I have the same trouble, they come and go strangely at different magnifications for no particular reason.

I’d like to see this sorted out. And also I’d personally like to see 3 styles of division - bar, beat & sub-beats - to make it nice and clear when aligning things in the middle of bars and beats.

Mike.

Hey Jules,
The grid seems a bit random to me too. Only advice I can offer is a) make sure your ruler is Bars and Beats (rather than timecode) and then set the Grid Type to Quantise and choose a quantise value that gives you the necessary fine detail on the gird. It’s a PITA having to do this rather than being able to set a standard grid resolution but it seems to work.
HTH
dbh

Yup - what dbh said.

Increase the quantize value, even to Q1/16 or Q1/32 and ‘stretch’ the project out across the main track window enough for it to show up.

OK, so the short answer is that there’s no way to change the visual grid/ruler divisions or resolution aside from zooming in.

I’ll log a feature request.

Many thanks

Jules

Did you try what dbh & I suggested? Did that not work?

Hi Jamusic

What dbh suggested was to have the ruler set to bars and beats, which I had already done, and to change the quantize value to say bars or beats. This does help a little with dragging, but it doesn’t change the grid lines or divisions visible in the grid and ruler, which was what I was originally asking. I just think it would be helpful to have a little more control over the level of detail shown here.

Truth be told, I find the snap functionality in the Project Window a little strange. For example, if I set a loop range in the ruler, but want to drag the whole range to just before the beat (overrriding snap), I can’t so this using a key modifier. I have to disable snap altogether using the snap button (I don’t think this can be assigned a key command even, but I could be wrong), and then drag the loop range. This of course means snap is disabled for the whole Project Window, so if I forget to re-enable it again, then the next copy/move command will be difficult.

This means I’m constrantly switching snap on and off whilst I’m working, so I can move locators around to positions just before the beat (otherwise loop-backs miss notes which are fractionally before the beat). Ideally I would keep snap on, and have it use quantize for the snap resolution, with quantize set to 1/16th. However, in order for this to be workable whilst I’m dragging and copying parts around, I need to be able to see more grid lines and ruler divisions, otherwise it’s close to impossible to drag and copy to the right place.

Sorry for the long-winded explanation, and thanks for your input.

Jules

Clicking ctrl while dragging suspends snap, I think.

I don’t think this works when dragging the loop range/locators in the ruler.

Which it really should…

Ok, I get it now. Thanks for the explanation.

I looked in the manual for the default key commands & found this on page 718:

Snap On/Off [J]

I always click the Solo button on the track or Mixer channel itself, so I might reassign this to [S] instead of [J].

But I hope that [J] speeds things up a tad for you there Jules. :slight_smile:

Hi Trailerman

I have the letter “a” assigned to the snap button as a KC, I do use it a lot, but you are right about the gridlines

Best Regards

Dave

Hey Jules,

I think you misunderstood my suggestion, or maybe not but I’ll try and explain it again anyway…

Set the “Grid Type” to “Use Quantise” (NOT Bars) and choose a quantise value that gives you the necessary fine detail on the grid. It still depends on your zoom level as to how many divisions show but it’s a lot better than using Grid Type of “Bar” or “Beat”.

Here’s “Bar”…

And the same zoom level with “Use Quantise” at 1/4

Cheers,
dbh

You’re right dbh - I did misunderstand your explanation. Many thanks for setting me straight.

I’ll give your suggestion a try, as getting more grid lines alone would be a big improvement. If Steinberg could add an option to show more ruler divisions, that would helpf further.

Thanks for your help.

Jules

No problem.

I’m still not sure it’s going to give you quite what you want. I also came here from another DAW and have been struggling to understand why this seems so cack handed. A separate visual grid resolution would seem to be the answer.

dbh

Hi dbh

The suggestion to change the grid setting to ‘use quantize’ in fact makes no difference to what I see, because I’m working at a zoom level that does not show any grid lines apart from full bars. I need to zoom right in to a level I would never normally work at, before I see a higher resolution grid.

IMHO this is not precise enough and needs to be changed. I agree that implementation here is clumsy, somewhat random and certainly not accurate or flexible enough for some users. FWIW I’ll log a feature request.

EDIT: feature request logged, all support gratefully received - http://www.steinberg.net/forums/viewtopic.php?uid=37934&f=182&t=60167&start=0

Jules

Ok - I did wonder what zoom you were working at. I’ve +1d your feature request.

I was just wondering; when you’re dragging and dropping at that kind of zoom level are you using any type of Grid + Snap Type? You must be otherwise it would be too difficult.

Just in case it’s helpful - when I first started experimenting everything was snapping to absolute grid - if you change the snap type to “Grid relative” it will copy/drag in relative rather than absolute increments. If you combine this with the “Use quantise” (for the snap type) it can be useful.

Stupidly the “Grid relative” setting appears to get lost after a while and there’s no key command to go directly to it (the only key command is to cycle through the snap type options). You can set key commands for quantise amount so I wanted to try and create a “Drag” macro that would set the snap type to grid relative and the quantise amount to 1/4 but it can’t be done.

dbh

Hi dbh

I use a relative grid all the time, and woud ideally use a ‘use quantize’ setting for the grid. However, if I can’t see the beat lines, and have quantize set at 8ths or 16ths, then copying and dragging is a fairly random affair. Therefore I have to use a bar or beat grid in order to make sure I’m not dragging parts to unhelpful locations.

Thanks for the +1

Cheers

Jules

I know this thread is four years old, but I stumbled into it with the same issue and my problem was not resolved from prior suggestions. However, I did find a solution that worked for me. My grid line was showing all measures but only beat 2 in each each measure. I wanted to see every beat in 4/4 time and no matter how far I zoomed in, still just beat 2. As for my solution, I found that I had to change the time signature on one of my Instrument Tracks. I accessed the Score editor through one of the tracks and noticed the time signature was in cut time. I changed that back to 4/4 and I am now seeing every beat per measure.

Solution: Change the time signature in Score Editor to desired beats per bar.

All the best