More unexpected things in the drum staff

Hi,

Spending my hours trying to rewrite a drum part from an imported XML. Most of it is thrown-away and I am now in the process of rewriting it in full (horn parts fairly ok so far). But then I ran in to this: If I enter a note in measure 44 from a up-stem drum kit part, then 41-43 goes blank. However, if I instead take a down-stem part, then it seems ok. Is this by design?
image

My guess would be that the previous whatever in the upstem voice is set to “End Voice” in the properties panel. This is a hazard specific to MusicXML, and more specifically to not unchecking the option to preserve Rest Visibility in Preferences > MusicXML before importing MusicXML.

The solution this time is to find the last visible (previous) note or rest in the Upstem Voice and unset “Ends Voice” in the properties panel. The solution that will lead to you not finding yourself in this position again will be to go to Preferences > MusicXML Import and turn off the offending option(s). For what it’s worth I deal with MusicXML with almost all of these options disabled.

I checked all the up-stem notes, no “ends voice” or “begins voice” on any of them. Deleted a full bar with up-stems that was bad anyway, no change. Only up-stem notes I can find is now in measure 1. Sending you the file via the inbox if you are curious. I consider giving this work up right now and write from a pdf instead. This was not the first problem :frowning:

It’s the rest at bar 31.

But actually that doesn’t fix it.

Turning on Voice Colors from the View menu revealed a lot of voices. I have no idea why you have so many different voices going on in the drum kit; can only assume that this is also to do with the way the MusicXML came in.

Well me too, I have no idea on why there are so many voices. Usually I only use the kit voices or slash or bar repeat notation, sometimes in combination (when it works, not so great for bar repeats). There is not much left in the drum staff now so I guess I need to reset it someway. Select the first bar, select to end of flow, press delete and do everything from the beginning? Would that work…?

I guess so.

Lots of voices is often the result of hitting Shift-V (which creates another new voice) when all you need to type is V to switch among existing voices.

Yep I know, but I haven’t used this even once in this chart :-/