Mouse jumps to start of event

I updated to Cubase 10.5 recently and I think an option must be enabled I’m not seeing, because it never used to behave like this before.

Whenever I select an event or midi region the cursor position will automatically jump to the start of the event or region. Is there an option to disable this?

Here is a gif showing my explanation.

https://gyazo.com/5a65115cd8f2fbb7f8c087865267f982

Thanks,
DMDComposer

Hi,

Disable Transport > Use Video Follows Edit Mode, please.

Thanks Martin! That was it. :smiley: