Mouse pointer behave different in Big Sur

After installing Big Sur I experience a change behaviour using my mouse during input mode.
I almost always use “Pitch before duration” when I input notes in Dorico, and after selecting a measure for copying it to another stave I usually click in the score to unselect the copied measure. But if “Pitch before duration” is on - and it it’s - Dorico “thinks” I want to input notes!
If “Pitch before duration” is off I had to double click a measure to enter input mode.
How can I tell Dorico that I want to use “Pitch before duration”, but only activate note input when I double click the measure?
Isn’t that the usual way?

This is how it’s always worked - it’s certainly how it works on my Catalina machine as well as my Big Sur machine. If you don’t want the grey ghost note, turn on the Select tool. You can set that as default by unticking Preferences > Note Input and Editing > Mouse Input > By default, enable note input using the mouse.

You are right - again!
Thanks a lot!