Mouseclick 'hangs' Cubase Elements 6 (on Mac)


I’m using Cubase Elements now and have already ordered the upgrade to Cubase Artist. Now, Cubase is letting me down! :frowning:

First: I’m using a Macbook Pro with OSX Lion.

What happens:

  • When opening Cubase the project assistant opens: when selecting any option with the mouse, the project assistant does not respond anymore. If I do not use the mouse but select the options with keyboard (tab-ing and enter to select option) it works fine.
  • When opening a project, again, the application works fine when pressing keyboard keys but when clicking an option with the mouse it hangs again. It seems like the mouse is pressed but it does not come back to state ‘unpressed’.

I’ve tried using different mouses as well as the Macbook’s trackpad but so far no results.

When it occurs I must force the application to shutdown (there is no ‘Not Responding’, however).

Any thoughts?

Many thanks,

You also tested different mouse drivers?

Greetz Bassbase

Many thanks for your reply.

Well, I’m searching for mouse drivers but since it is all Mac OSX it’s not as clear/obvious as with PC to find separate drivers.

Is Cubase the only one app, where you have problem with your mouse/mices?

I have this same problem on 2 different machines I notice if you leave it for a bit it will work

Yes, I agree on that because now it’s working fine again. I had the issue twice now… and both times it was resolved without knowing cause and solution… :open_mouth:

Yes, I think so. I also tested with browsers and some office applications and that worked fine.

Maybye trash preferences could help.

Yes, I did that too but no results…

Ah, I think this happened to me a few times (on a macbook pro as well), and I’ve found a possible “solution”. What seems to happen is Cubase is selected, but thinks that you’re outside of Cubase, for example, in another application or on the desktop. Thus, any mouse clicks on the project manager doesn’t read the clicks. I believe that I resolved this by clicking on the desktop or another application, and returning to Cubase.

Then again, I don’t think this is the precise source of the problem, because I haven’t been able to reproduce it.

Ok, thanks, I don’t think I tried that. Currently it’s working fine but I’ll give it a try when in occurs again.

Ok, I think I discovered the issue. It has to do with a conflict caused by a third party display driver (Airdisplay in my case), my laptop model and OSX Lion:

All is described here: