MOX8 Editor VST with Cubase 8 Artist

Hi everyone,

I installed my new Cubase Artist 8 program. When I open it, I always get a message window that reads,"Missing Ports, Yamaha MOX6/MOX8-1 Left Yamaha MOX6/MOX8-2 Right, I/O Out, Unmapped ports. Then the VST Editor pops up and gives me a Port Open error.

For my new project, I choose Yamaha MOX6/MOX8 with VST editor (2StereoRec Mode). My MOX8 is set up this way. I also have it in Song mode open to an empty song. Funny thing is, I can record MIDI but there is a glitch. I set Track 1 to record the Grand Piano. I must click the Monitor button or I don’t hear the piano. I record a sample track. Go to Track 2, use the Editor VST to select a bass voice. I record Track 2, but it only plays a piano voice while I record but plays back the exact bass I selected in the Editor VST. What gives? I never had so many headaches in AI5!!

For each track, I have the MIDI inputs set to All MIDI Inputs. The output gives me a choice of:
Not Connected
Yamaha MOX6/MOX8 - 1
Yamaha MOX6/MOX8 - 2

  1. Yamaha MOX6/MOX8 VST – MIDI In
    VSL-Out 1

No matter what I choose for an Output, I always here piano on all channels, but Cubase records the correct instrument. I can’t wait to hook up My Tyros 5 and see the horror stories that unfold!

Ideas welcome, but please speak English. I’m really having a lot of problems with this so-called, “professional program.” I’m now in my ninth hour of getting nowhere. Cubase AI worked perfect. I uninstalled it, by the way. That in itself may lead to my ultimate demise. Perhaps I’m too old for this crap!

Thanks.

  • Lee

Update folks…

I can hear the Bass played on Channel 2 when I manually set the MOX8 to MIDI Ch 2. In Cubase AI, that message was sent automatically. Hmmm? Did I configure Cubase AI differently in the Preferences dialog box?

It gets worse…

Now, when I play the piano, all kinds of windows start popping up in Cubase. The List Editor, Score Editor, Mixer…you name it.

This is one messed up program…grrrrr… Steinberg is going to get it right back through their front window!!

Does this help?
http://www.steinberg.net/forums/viewtopic.php?f=226&t=69713&start=25#p440451

It sounds like your MOX is acting as a “remote” for Cubase rather than a VSTi.

Assuming you’ve got the MOX8 connected to the DAW via USB, first check you have:

  1. the latest OS on the MOX8 (V1.02)
  2. the latest Yamaha USB drivers loaded (Windows - 1.9.2, MAC - 1.9.2-0)
  3. the latest version of the MOX8 Remote Tools installed (1.1.4)
  4. the latest version of the MOX8 VSTi Editor (WIndows - 1.6.3, MAC - 1.6.5)
  5. Cubase 8.0.10 installed

If you can confirm this config and

A) whether you’re using Windows or MAC
B) how you are routing the audio output from the MOX to the DAW

perhaps we can offer some help. (I have a MOX and a MOTIFXS working successfully with C8.0.10).

Hi guys…thanks for jumping in here.

Jenks, I just finished updating everything because most versions were out of date. Also:

  • The MOX8 is connected to the Audio In L/R of my Steinberg CI1 interface.
  • The two audio outs go to my Yamaha HS8 monitor speakers.
  • The interface is connected by USB to a port on my PC (Windows 7 Pro, Quad core, 4 GB RAM).
  • The MOX8 is connected to a USB port on my PC.
  • No hubs are used in the signal path, except for the dongle. I even tried connecting it direct-same problem.
  • The MOX8 is in Song mode and an empty song is displayed.
  • When I open Cubase, I select Yamaha MOX6/MOX8 with VST editor (2StereoRec Mode).

I open Cubase 8, and I still get the Missing Ports message, which I believe is the root of all evil here. I never had this issue with AI5. It’s as though Cubase 8 needs to be configured every time I open it, which shouldn’t be happening.

Thanks :slight_smile:

  • Lee

Here is what I’m seeing after Cubase opens. Notice the orange-yellow message that reads, “Audio outputs not connected”
Cubase 8 Opening window.jpg

Progress report.

I read an article by Bad Mister that stated something to the effect, “The Editor VST doesn’t work in Cubase 8 yet. It should by about mid-March.” I don’t know how valid that comment is, but no matter. I have it working providing I select Empty and not Yamaha MOX6/MOX8 with VST editor (2StereoRec Mode) from the Cubase Hub when I start Cubase.

I figured out some routing and can now record several MIDI tracks from my MOX8. I saved that project as a template and will work off it for further projects. The only difference between AI5 and Cubase 8 is I must still manually select the tracks in the Track (F3) area of my MOX8 to hear the instrument I’m recording on that track. There doesn’t seem to be any way around that. No matter, I’m happy if that’s the only thing that is different from AI5.

My next task is to import a MIDI file created on my Tryos 5, and see if I can establish communication between the Tyros 5 and Cubase 8. By the way, to implement all this, I used the MIDI Device Manager and installed the Instrument Definition files for both keyboards. It’s so nice to have a version of Cubase that has the updated files!

Now that I’ve recorded a simple 5 track MIDI melody, I’ve had time to explore some of the finer features of Cubase 8. The ability to move windows to my second monitor (something you can’t do with Elements or earlier–not that I could see) is worth the price of admission.

More to follow. Thanks for listening to me rant. Glad I’m not the first!

Good to hear that things are working better for you.

The VST editor is now working as VST3 plug-in with my Rack XS.
The two Cubase templates also work as expected.

Bad Mister is a genius! I recently posted my concerns as a new user here: https://yamahasynth.com/index.php?option=com_easydiscuss&view=categories&Itemid=851

He provided an incredibly detailed response that put me on track.

Thanks Frog. So far so good. The Tyros 5 patch went better than I thought. I guess it’s all about signal routing.

Let the creativity begin!

Hi Lee,

Did you ever get this working with the Cubase template?

Frustratingly, the VST editor editor worked straight out of the box for the first week of my v8 evaluation, but now, whenever I open a new project I get the Port Open Error, and I haven’t changed anything! I used to get this all the time with AI too. I have followed all the setup guides, and as I say, it worked like a dream out of the box but something seems to have gone wrong.

It’s very frustrating as I was considering purchasing v8 but might just go with something simpler if I can’t hook up my mox-6 properly.