MR816 'failed to initialize' message

Hi all, I’ve read as many posts as I could find on the subject but I still have no solution.

Yesterday the fire-wire cable behind the MR816 came loose while playing audio, the computer semi-crashed and the audio cut out. Since then I am having trouble getting the MR816 operational again.

Current status:

  • ‘failed to initialize’ on startup
  • MR updater says ‘Searching for FW device’
  • Mac system profiler shows FW port and sees the MR816, however the Audio-MIDI utility does not
  • MR editor says ‘no device found’

I’ve tried:

  • Uninstalling and re-installing drivers multiple times
  • Resetting SMC and PRAM on the Macbook Pro
  • Resetting the MR816 (holding pad+vol1 on startup)
  • Restarted everything multiple times
  • Connecting cable to the 2nd FW port
  • I even wiped the hard-drive and did a clean install of Mac OS to no avail

I am running Yosemite but had the same problem on El Capitan.
The next step is to buy another FW cable (FW 400 -> FW 800)

Am I missing something here? Could the cable be the problem considering it is being recognized in the system profiler?

Update for anyone experiencing the same problem -

I managed to solve the issue by running the MR Updater a bunch more times, it eventually went from ‘searching for FW device’ to ‘FIRM’. I also tapped a bit on top of the interface near the back outputs/FW ports when it happened to work, I’m not sure if it had anything to do with it or if it was co-incidental…

Once I got the ‘FIRM’ prompt, I reinstalled the firmware and now the interface is recognized. Maybe the FW cable is sketchy but for now it’s working. Moral of story MR816 does not like hot-plugging.

Hi,

I was wondering it you could give me some tips on how you were able to run the MR Updater. I have a similar issue. My interface worked just fine until it stopped connecting. I have uninstalled and reinstalled everything but it just won’t connect. At one point it connected and when I restarted the computer I go the same message “Failed to initialize”.

To run the MR Updater, I’m turning off the device and holding down the quick connect 2 button and the multi 1 button. But when I run the MR Updater it just says searching for device but then it says no device connected.

It’s really frustrating! I would greatly appreciate any help.