MR816x and Presonus Digimax D8 wordclock problem

Hello everybody!

I would like to ask you for help because I think I read everything what I found in internet and unfortunately no answer and no idea what to do, so maybe here an expert will be found here? Help please!
I connected via ADAT (Toslink) Presonus Digimax D8 to my Steinberg MR816x to achieve additional 8 ADAT ports. Because I want to have MR as the master I connected Digimax (in) with MR816 (out) with BNC 75 Ohm cable to synchronize wordclock. I checked MR was defined as master with internal clock as the source and switched Digimax to external clock. What is the effect?

  1. Loud white noice (close to 0dB) what (as I think) means wordclock is not synchronised but
  2. Digimax reacts if I change rate from 44 to 48 because it changes as well each time so it seems it should work properly :frowning:
  3. Recording is possible only if wordclock in Digimax is set as internal but there are two masters then…

So I tried to set MR816 as the slave but… there is no option in Cubase and MR Editor to choose other option than Master :frowning: Of course I tried all different options in clock source definition - no changes, as wordclock master only MR816 is available.
All drivers are actual…
Is anybody here to try to solve this issue and help? Is there something I do in a wrong way? I am lost :open_mouth:

Intel Core i&-4790K CPU 4.00 GHz, Ram 32 GB, Windows 7 64 bits, Cubase Pro 8 64 bits, Steinberg MR816x, many plug-ins from Waves mainly.

Connect both in and out on the ADAT toslink, and don’t use the BNC wordclock. That would be my best guess.
Wordclock is transmitted on the ADAT toslink anyway.

Thanks for your answer however I have just found other solution: BNC has to be connected by T-connector and terminated by BNC terminator 75 ohm. It works, the issue is solved.

Yes it’s like the old 10 mbit coax networks, it needs to be terminated.