MTC sync with PT master issue

Hi there,

Glad to be a new member of this community!

I have two very distinct issues with syncing Cubase via MTC from PT. Everything is working great in terms of setup and basic usage. I have PT generating MTC and sending over IAC Driver Bus 1. Cubase is set to start after 0 frames and it’s reading and they are syncing just fine… well, reasonably fine…

My setup is that I have a large PT project for guitars and vocals etc, then I sync Cubase for the drums because PT drum editor is nonexistent and programming drums in PT is a living nightmare. Before you ask, no I’m not willing to use Cubase for everything.

Issue #1:

If I move the transport in PT to the start i.e. 00:00:00:00 then start the playback, Cubase will start almost immediately but not quite. That’s expected as timecode isn’t perfect. However, this makes it difficult to understand where I should place my drum midi clips in Cubase so that they are in fact in time with the guitars in PT.

Issue #2:

As I mentioned earlier I have a large scratch pad project in PT. For this reason I often wish to start playback much later in the session, as I also wish to have a large scratchpad project in Cubase. For example, if I start the playback at say 00:09:10:00 or 00:09:30:00 in PT, then Cubase will start at the same point regardless of if I start PT at …10:00 or …30:00 and it’s very difficult to get any meaningful kind of timing or start point.


So my questions are as follows:

  1. Is there a way to display timecode in the timeline on Cubase so that I can reasonably expect to visualize where my drums are supposed to be placed?

  2. Are there any other tips or tricks in relation to this kind of setup that can help me achieve a meaningful time sync?

  3. Why is Cubase starting at disparate points when I start PT later in the session? Is this a known problem? Have I done something wrong? Have I simply assumed too much of MTC?

Alternatively, I could simply compile my guitar parts and start a fresh session just for that song and do the same thing with the drum parts. This would mean waiting until the guitar parts are completely written to then proceed with drum parts, not ideal. This also doesn’t solve my issue of timecode visualization in Cubase as the delay even starting at Bar 1 in PT isn’t perfect.

I’ve just found the timecode display for the ruler, so that problem is at least solved. Apologies if that was obvious, an issue of the wrong keyword search!

I will test now to see how I can get a more meaningful sync.

Actually I just realised this is not going to work with timecode, as I need to see it in bars and beats.

Also the issue was that I had not set tempo within Cubase to match PT. An obvious mistake.

Hopefully this helps someone in the future.

I’ll start with the obvious question: Do you have both DAWs set to the same framerate?

For the timecode display, you might leave the main ruler in Cubase set to Bars&Beats and insert a Ruler Track. This shall be set to timecode.

You can also setup Cubase’s transport panel to display both Bars&Beats and Timecode:

Let me know if you need help making those settings.

With MTC it is advisable to start playback always a few seconds earlier than you normally would do. You might have to insert some seconds of silence at the very start of the project in ProTools to ensure sync when the music starts.

1 Like

Oh that is BRILLIANT! I just discovered I can do the same in PT as well. Thanks for the tip.

Frame rate not sure probably not, but tempo was definitely not set properly. Cannot find the option to set that in Cubase.

Either the v12 docs are wrong or it’s just not possible in Elements

Menu Project → Project Setup

1 Like