MTK 22 and Cubase 5.1 playback issues

Just starting to dive into this hybrid recording stuff, and have run into a snag that is frustrating me. I believe my parameters are set right, but not 100% sure. I am recording and attempting to route back through the mixer. My 1-16 inputs in Cubase are mono, corresponding to the MTK channels, and my outputs are the same 1-16. I record the tracks fine, but they will not play back through the MTK. USB buttons are depressed on the mixer. What the hell am I missing? Thanks

You probably have to give a bit more information. Take some screenshots and post them here and show the audio connections window (outputs) as well as the window that shows the studio setup - with the driver selected. Just to make sure you’re actually routing things correctly in Cubase.

Select the driver below to show more info:


I think there is a list of inputs and outputs that are available and will show to the right when you do that and you can make sure they’re all “active” or whatever it’s called. I’ll check my setup later.

Tracks record fine from mixer to corresponding channels in Cubase, but when I send the tracks back to the MTK 22, I get no signal to the mixer channels. Also, on playback, the channel meters on the out channels in Cubase show no activity.

Hmmm… So you have set the output of audio track 1 to output 1, audio track 2 to output 2 etc.?

It’s odd that you wouldn’t get signal on the output channels if you manage to record and then play back fine.

Yes, it has me stumped. I’ll keep messing with it. Thanks

What does the actual track routing look like then? I mean, it’s not something easy like having monitoring set up incorrectly in preferences / on tracks?

You’re asking a lot of this old man. :wink:. I’m really not concerned with live monitoring, as my main objective is to record my band at a live gig, then mix down later. The funny thing is, during recording, the output meter is reading as well as the input, so why not on playback?

That odd behavior is why I was asking, because of potentially incorrect settings. I don’t typically record in Nuendo (I use PT in studios for that) so monitoring isn’t something I can nail down right away. But anyway, this all looks to me like you’re just missing out on some setting, and I know that I’m asking a lot of questions but I think you’ll eventually have to provide all of this anyway.

For example, in some DAWs when you set an audio track a certain way it’ll monitor input only. So if you have your track parked and there’s an incoming signal that will go through. If you press record that’ll go through. But then if you press play the behavior may be the same or it may change, depending on settings. In some DAWs (like Pro Tools) it can be set so that even after you’ve recorded the recorded signal won’t be played back if you press play - in those cases you have to deselect the monitoring function or set it differently in order to hear audio on playback.

So, check audio track settings, and check monitoring settings in preferences.

Thanks much. I’ll keep snooping around in the settings and see if I can find the problem.

Eureka! I have found it! Like you said, something simple. All I had to do, was click the monitor icon off on the channels. Presto! Thanks so much for your help.

1 Like