Multi-Channel Export Drops FX When Audio and FX Tracks Are Routed to Intermediate Group Tracks

When performing a multi-channel export, effects are dropped under certain conditions. For example, when an audio track and an effect track are routed to respective group tracks and those group tracks are routed to a “Master” group track, effects are dropped from the export, even if Solo Defeat is enabled in the effects track and downstream group and “Master/Groups/Sends” is the chosen Effects export option.

However, routing either the audio track or the effects track directly to the Master group track corrects the situation and effects are successfully exported with the audio track. Unfortunately, this isn’t a good permanent solution, being that it requires complex rerouting on large projects.

This wasn’t the case in prior versions of Cubase and Nuendo. My projects routinely employ “stem” group tracks for “Bass,” “Guitars,” etc., and a dedicated “Effects” group track so effects can be managed / muted en masse.

To replicate this failure, perform these steps:

  1. Launch Nuendo
  2. Add a “Master” group, routed to an Output channel
  3. Add a “Guitars” group, routed to the “Master” group
  4. Add an “Effects” group, routed to the “Master” group
  5. Add an Effect Track, “Echo,” routed to the Effects group, and select an appropriate echo effect
  6. Add a “Guitar” Audio track, routed to the Guitars group
  7. Activate a Send in the Guitar track. Choose “Echo.”
  8. Enable Solo Defeat on the “Echo” effect track
  9. Enable Solo Defeat on the “Effects” group track
  10. Record an audio take into the guitar channel
  11. Select File > Export > Audio Mixdown…
  12. Under “Channel Selection,” choose “Multiple” and select the “Guitars” group
  13. Locate the “Effects” option and choose “+ Master/Groups/Sends (CSPM)”
  14. Press the “Export Audio” button
  15. Audition the resulting exported audio file. Note that the echo effect is absent. [It should not be.]
  16. Reroute the “Echo” effects track to the “Master” group (thus bypassing the “Effects” group)
  17. Repeat the multi-channel export (steps 11-14, above)
  18. Audition the resulting exported audio file. Note that the echo effect is present.
  19. Reroute the “Echo” effects track back to the “Effects” group, as before
  20. Reroute the “Guitar” track to the “Master” group (thus bypassing the “Guitars” group)
  21. Repeat the multi-channel export (steps 11-14, above), but choose the “Guitar” track to export
  22. Audition the resulting exported audio file. Note that the echo effect is present.
  23. Scratch head

I’m running the latest version of Nuendo (v12.0.40) on Windows 10 Pro.

I hope this is helpful.

That is bad indeed.

Let me share my workflow from mixing 20+ years of music.

All STEMS go through the exact same Mix Buss. to do this is more tedious, but at least gets you there. I treat the final printing of my mixes as a Holy Thing. Something to be done slowly, methodically, and carefully.

What I do in Nuendo is:

1.Print the Main Mix.
2. Print a TV Mix, muting only the lead vocal(s).
3. Begin the STEM print process.
3 a. I being with the percussion section, MUTING anything that does not belong there, and leaving the temporal effects unmuted.
3 b. I move onto the bass instrument(s)… same process.
3 c. etc until all instrument groups are printed out.

All STEMS have to go through the MAIN MIX BUSS. Otherwise you are not using the MAIN MIX BUSS effects on each STEM, and the end result will not sound the same once you reassemble the stems if needed later on.

I am always perplexed why many engineers always seem to want to get through the making of their Final Print as fast as possible. To me, that is the most crucial point, not the least important.

I do not use the “faster than 1x time” process either, or offline process. Mainly because I have always had horrible luck with that.

That’s my 2 cents…


PS I’ll try to replicate your bug here when I can this week, and report back.

1 Like

Thank you for looking and for verifying!

I think our workflows are mostly similar. This example is stripped down for clarity, but I also route everything through a Master group/bus.

I also share your “Holy Thing” ideal. But, my nemesis is human error, so I’ve come to rely on automation. To this end, my templates incorporate a dozen predetermined subgroups/buses for “Drums,” “Bass,” “Synths,” “Horns,” “Strings,” etc., all routed to the aforementioned Master bus, and whether or not they’re ever used in the project. New tracks are usually added to the project via Track Templates pre-routed to the appropriate subgroup. It keeps me organized from the start and, when it comes to exporting stems, I simply select the subgroups to print and Nuendo automatically does the muting and routing. Well, usually. :sweat_smile:

Speaking of human error, now I only wish Nuendo could tell when I’m exporting rough mixes vs. master mixes and automatically deactivate my Master bus limiter! Oh, if I had a nickel…

Thanks again! I appreciate your assistance.

Why do you expect to hear the FX if you route it to an extra subgroup that is not part of your export?

This enables the possibility to export the FX as a dedicated stem.

1 Like

But it is part of the export. I mentioned it twice.

…even if Solo Defeat is enabled in the effects track and downstream group…

8: Enable Solo Defeat on the “Echo” effect track
9: Enable Solo Defeat on the “Effects” group track

To be absolutely clear, Solo Defeat, in this context, enables the Effects subgroup in the export. Without it, you would be correct - the Effects subgroup would not appear in the export.

I can’t see why you are calling this a bug. What do you do if you want to export dry guitar group in this context?
Solo defat shouldn’t be related to where the bus goes. If 2 sources are send enabled to the fx and you want to export them at once, where do you think the fx go?

Mute the Effects group track. Or, disable Solo Defeat on the Effects group track.

Have you followed the steps I provided to duplicate the problem? It’s a complicated issue and requires some effort to understand. Also, understand that my workflow might not be familiar, or ideally suited to your needs. That doesn’t make it wrong.

Here is a diagram. The important thing to realize here is this: When the Guitars group track is bypassed, the multi-channel export is wet. When the Effects group track is bypassed, the multi-channel export is wet. But when neither is bypassed, the multi-channel export is dry.

Nevermind workflows or tangential what-if scenarios. If, in this context, A = C and B = C, then A and B should also = C. This is the fundamental question. If you can explain to me why A and B are mutually exclusive, then perhaps it’s not a bug. Good luck.

As a quick workaround, do not create a “effects group.” Just mute them if you do not need to print them for some reason. If you need to mute them all together, you can link them, and only link the Mute button.
Each effect will feed the Master, and should sound out when making the stems.

1 Like

Good suggestion!

I’m always afraid to make sweeping changes at the final stage, but I’m gonna try rerouting all of my effects channels (Q-Link) in one go, bypassing the Effects group track, do my multi-channel exports, and shut down without saving. That seems pretty safe. :grimacing:

Thank you!

1 Like

Or “save as…”. a new version of the session. I do that often. Call it “PRINTS” or something equally useful.

I’m actually inclined to agree with the other poster who basically said it’s working as it should. I can’t really explain why I think so other than to say that it appears FX and Group channels are just treated differently. So once you ‘break’ the ‘straight path’ from FX channel to a group you apparently lose the ability to include that signal in the export. Perhaps they felt the logic to determine which groups should receive and output what audio becomes a bit too complex when you “nest” routing the way you did in that first example in the diagram.

My normal way of working is to use outputs for all mixes and stems I need (post production) and use them as sources for exports, and I never have a problem that way.



This is exhausting.

From my original post:

Are you suggesting it was broken in Nuendo 11 and now is fixed?!

No I’m not. I don’t ever export with groups as my source so this isn’t something I’ve ever had to deal with, so it’s “new” to me.

It’s possible that it was broken in v11.
It’s possible it’s broken now but was good in v11.
It’s possible it wasn’t broken in v11 and isn’t broken now and is just a design choice.

Either way I recommend using outputs as a ‘final destination’ for mixes and stems and export from them instead.

Could you clarify where you exported each one of these?

  1. Failure case - from Guitar Group
  2. Success case - from Master
  3. Success case - from Master?

Am I right?

Good question.

To be clear, all three examples represent a multi-channel export, with the Effects option = “Master/Groups/Sends.” So, the final export should incorporate the influence of the Master group track and the Stereo output channel. The point of this exercise is to produce a Guitars stem - that is, export the Guitars group track.

  1. Guitars group export
  2. Guitars group export
  3. Guitar audio track export. [I wouldn’t normally export an individual audio track as a stem, but this exercise reveals an important detail - that the issue isn’t isolated to the Effects chain. Bypassing the Guitars group track also ‘fixes’ the problem - that is, incorporates the Effects group track into the export.]

Thank you for looking at this. I appreciate your effort.

Ok, I just did a quick test now. The clip names are derived from the channel name, so if it says “guit GROUP” then it’s the guitar group that was selected for export:

Seems like the behavior you described, yes? “Echo” is routed to “FX Group”.
It’s in Nuendo v11 though.

Now with your workaround outputting the Echo FX track to Master Group:

Same thing on Guitar Group.

Export settings:

I’m tired. I had a long day. Did I miss something in the repro?

I think I know now why I think it makes sense to me.

To me it seems like the “baseline” behavior is rendering whatever is present at the output of the “node” you chose in the signal chain. So since there’s no Echo effect summed into the node you chose, the “Guitars group”, no effect is recorded. If you select to include effects after that node, for example on the master, they are included. But it refers to effects in your signal chain to the output, not effects added through summing.

The option to include a signal from a send seems to only apply to audio tracks.

Again though, I’m tired so perhaps I’m not thinking straight. But at least with the above view on it the behavior seems consistent.

1 Like

Thank you for your effort.

The issue I described cannot be replicated on Nuendo 11. It’s specific to Nuendo 12. If you look at my routing diagram, above, the first routing example fails on Nuendo 12 but was working fine on Nuendo 11.

That’s one of the reasons I’m inclined to call this a “bug.” When program logic changes from one software release to the next, it’s typically accompanied by an explanation, like “we’ve changed signal routing logic to mimic that of a Neve 8028.” But when things change without explanation, it’s usually unintentional. This comes from a programmer with 40+ years experience. I’ve coded in everything from assembly language to C++ to good ol’ HTML (w/ ColdFusion and MS SQL Server on the backend). Good programmers document everything. By extension, if it’s not documented, it’s usually a bug. Not always, but usually.

Thanks again.

1 Like

Can you take a look at what I did though and explain where my reproduction steps went wrong?

I’m not sure what you’re trying to do. Are you following the steps to replicate the problem from my original post? For the purposes of verifying that the steps do not fail on Nuendo 11 as I’ve reported they do on Nuendo 12?

And, you’re saying you’ve followed those steps exactly but it does fail for you?

It’s difficult to say why it would fail for you but not me (and a few others who’ve chimed in to say they export stems this way too). Is “RX Group” supposed to be “FX Group?” Are you routing your FX (echo) track to the “RX Group?” If so, do you have Solo Defeat enabled on the RX Group and the FX/echo track?

You’ve done all this and you’re not getting a wet export? Hmmm…