Multi midi input from the same midi port

Hi there. How to make multi midi channel input from the same midi port into the same VST in Cubase Pro 10? Even though the vst is set to accept all midi inputs from the midi port used and midi monitor confirms the correct different incoming midi channel numbers into that track in the messages sent, any vst on it just keeps accepting all midi messages as coming from midi channel 01 only. It would not make sense to use input transformer, as the midi channels are already in the correct number. I know beforehand that the vst accepts multi midi input and the virtual port used is also correctly set, as it already works as expected on other hosts. Could there be something in between Cubase and the Vst that is missing or any additional configuration? Thank you.

Hi and welcome,

Cubase always get data of all MIDI Channels to the track. If you want to limit it to one MIDI Channel only, you have to use Input Transformer.

Make sure the Virtual Instrument is multi-timbral (can work on multiple Channels).

Hello Martin, thanks for replying. I am sorry but that just does not seem to be the case. Even though I am using a virtual midi port with 16 different midi channels into a vst (which supports multi midi input) and set “all channels in” in that track, the VST just keeps recognizing channel 1 as the only channel number. I am using midi channels 1 to 8 from the same virtual midi port and the vst just keeps detecting midi channel 01, no matter what.

I do not want to limit the midi channel number, I want to do exactly the opposite, hence, midi input transformer is not necessary. What I also would like to understand is why midi monitor on that tracks correctly translates the midi channel numbers coming from that midi port (midi channels from 1 to 8) but any vst with multi midi input support just keeps recognizing all midi channel numbers as being only channel 01 and nothing else on that track. This same behaviour does not occur on other DAW (like Ableton, where the vst correctly can detect the multi midi channel input numbers)

This exact same behaviour also keeps happening with any midi controller (hardware) with multi midi channels out support, not just virtual ports. In a second computer running Cubase 10 Pro the same thing happens.

I just want to use multi midi channel outs from the same midi port to send CCs messages from a midi controller to the same vst, just this. For that I need the 16 midi channels (if I use the 16) to communicate with the VST, but VSTs in Cubase just seem to “pick” channel 01 only, regardless of the real midi channel number the midi messages are comming from.

Maybe this works correctly on Cubase 9.5 , I do not know… I am on Windows 10 with Cubase 10 Pro.


Could you try in Cubase Safe Start Mode?

Double check Preferences > MIDI > MIDI Filter. Make sure none MIDI Channel is filtered out.

Everything seems pretty standard (not filtered), I am sending a screenshot (in safe mode).
Thank you again


In Safe Start Mode there are no MIDI Channels filtered out. Just make sure the Channels are not filtered in the common start mode too, please.

Nope :neutral_face: Everything keeps the same.
Could this be a Windows version bug in Cubase 10 Pro?