multi problem

I’ve notice a problem with the multi programs. For example…
I load the multi “Upright & Piano”, then i play a C major chord on a bass sound with notes c2 - e2 - g2 and hold it. Than I play the same chord 1 octave higher with the piano sound, so c3 - e3 - g3. Now, when I release one of the 2 chords, also the other one stops, like midi note off affects both sound on the split. This is terribile, I can’t play!
Is it only a problem of mine or may it be a bug?

thank you

Yep, confirmed here too (also in Halion 4 with the same “Upright & Piano” patch)

I’ve bought halion sonic, but with this bug it’s unusable for me… I’m a keyboard player and I do various split during live gigs… it’s incredible such a terrible bug…! How can we ask for a fix? I want my money back because I have to buy another vst… incredible!

I think I have a solution for you to try.

With the patch “Upright & Piano” the MIDI is split at the “MIDI” tab under “key”, but you can also split it another way.

Set the keyrange in “MIDI -> Key” from both instruments to the full keyrange (C-2 to G8).
Then go to “Edit -> Program -> Ranges” and set the desired ranges for both instruments. This way it should work like intended.

Of course you could always send in a support ticket, your problem is easy to reproduce and when you are depending on splits, quite annoying.

I will try to do this, but it’s absurd I have to do this in a professional vst! I always use splits with transpose because I’m a keyboard player…
What does it mean “Of course you could always send in a support ticket”? I don’t know what is a support ticket… I would like Steinberg will fix this bug, I think it’s not so complicated for them…
Thank you

Sending in a direct request for support via MySteinberg > Support Request Form, will give you a better chance on an answer or solution instead of this forum.

Personally I wouldn’t call it a bug. Stock patches just doesn’t work the way one traditionally expect from splits. But it can be set up exactly as you want with the method I mentioned.

I sent a request for support some days ago… and they answer me this is only a problem of mine, probably a bad installation or settings, and not a problem of the software!

Maybe point them to this thread, because I too can reproduce it in Halion Sonic and Halion 4.

done!

The alternative way works… thank you…! it’s strange programming not from the “midi” page but at least I can do splits!

This is not really a bug. If you look at the midi page for the Upright and Piano multi you will see that both instruments have been transposed which causes a midi overlap. If you remove the transpositions (set both values to zero) the split will play as you expect. If you do need to transpose either instrument do it in the edit page for the instrument (in the pitch tab). I think this is just a case of poor programing by Yamaha as this is what they should have done when they designed the multi.

Slight mistake in previous post. If you do need to transpose a multi instrument use the “edit”, “program”, “ranges”, “octave” buttons (using the pitch tab octave control applies some form of filtering effect to the octave change!).