Multiple Midi interfaces port naming

Ok I’m stumped, time to call in the big guns. I have a unique problem with a complex setup. I’ve use Cubase on Windows platform since VST 3.5. MIDI only version as far back as late 80’s on an Atari 1040ST. So I’m not a newby, but I can not figure this out. I have (8) MOTU MTPAV’s. Dell Workstation w/Dual Zeons, 32gig of Ram, Windows 10 along with (4) MOTU 24I/O’s. Loaded the correct drivers, everything is great. Cubase does see all the interfaces. Here’s the problem 20 keyboards, 50 sound modules, drum machines and samplers on 64 ports of midi. I have on several occasions named all the ports. Everything is still wonderful. Then I shutdown the computer for the night. When I restart the devices that I assigned to the port aren’t connected being reported as missing and the interfaces show up with different numbering. Does anyone know how I can get the interfaces to not reset. The power and usb doesn’t change. help please. Everything worked on Windows 7 and Cubase 8. What am I missing? Any help would be greatly appreciated. Thanks in advance.

What have you changed in the meantime?

Using any virtual MIDI ports ?

2 changes, Windows 10 being the catalyst, I had to add 3 MOTU’s and subtract 3 MAudio 8ports because the Windows 10 drivers for the Maudios wouldn’t let use multiple interfaces. Now I have 64 identical ports with a single number prefix being the only identity mark. No virtual ports. I’m probably one of the last midi production dinosaurs left. Hardware has pretty much been replaced by software equivalents. Naming the ports is a luxury. But getting them stationary so I can attach device scripts is a must for my setup. For years I’ve used this work flow. Select a sound source, pick a sound, track/edit/mix down to audio. All the years of gathering equipment with great a/d converters, preamps and filters. Man right now I’m crippled.

Are you using ‘powered’ usb hubs and have you checked if they still work OK?
Are you sure the port naming has been correctly stored in the devices?

When i upgraded from windows 7 to windows 10 I had some issues with folder permissions like the Cubase 8 profile folder and VST folders. I had to manually set these to full control. After this most of the issues I had where solved. After a clean installation of windows 10 i did not encounter these issues anymore.
Just a few hints that pop into my mind…

I’m using (1) 7port sub powered hub. You can’t name ports in window with the MOTU’s with clockwork only on Mac. They name correctly in Cubase. But if I restart I lose everything because the drivers name the interfaces differently

E, I would post on Gearslutz in the Win 10 thread. There’s a MS guy in there, Pete, he’s very nice and knowledgeable. On top of that, one of the big changes that Win 10 brought was a new MIDI engine, maybe this has something to do with it? Pete would know, I suppose!

EDIT: He’s on this forum as well, actually: https://www.steinberg.net/forums/memberlist.php?mode=viewprofile&u=60489

Happy hunting, hang in there! :slight_smile:
Benji

Thanks for the lead!

This sounds like a problem with loading your Windows profile following the upgrade (a similar issue to the one Nickeldome has described). If you’re still using a local account to log into Windows then you could try the following Microsoft instructions to Fix a corrupted user profile. On Windows, the names you assigned the ports are stored in the Cubase setting folder, so for example, “trashing prefs” as often recommended here will delete them. That folder in turn is stored in your Windows profile, so if Windows can’t load your profile, the settings are lost. A clean install of Windows should fix it, but that will also destroy everything and mean weeks of reinstalling and configuring applications if you have a complex setup (and it sounds like you do – 64 hardware MIDI ports? Respect!)

It may also be that, with the renewed detection of MIDI ports following the upgrade, Windows is simply having a hard time with so many registry entries. There are some useful instructions over here.

Thanks Mr SoundMan, that gives me a new place to look