Multiple voice rests (Fugue style)

I’m trying to replicate the rests in RH bars 1-3

but do not succeed.

This is what do:

  1. Select rest
  2. Change to down stem voice 1
  3. Force duration
  4. 6
  5. , (rest)
  6. y

or SHIFT+B + ‘rest’ for full bar rests. But nothing happens. What is the correct method?

Do you have notes entered in the downstem voice yet? That’s a requirement.

I have this so far

Are the upstem rests explicit? Just guessing here.

No sure, I imported an XML file and have not done much to the file (with all settings OFF). How can I check rests?

I might try entering those rests explicitly first.

My guess is that the first purple rest in the top staff (in bar 3) has the Starts Voice property on. If that is the case, try turning off that property. Then if you select the rests in the previous bars and use Rest pos. (in Properties) to move them up or down, it hopefully will expose the rests in the second voice.

But explicit rests would override this setting, if working correctly.

No Start/End voice settings are active for bar 3.

I think I have managed these situations before, but I cannot solve this case, for some reason.

What happens if you enable note input on the first (or second) rest, change to down-stem voice, press Shift+B and type rest into the popover?

It doesn’t work. I was able to add whole rests to those bars manually and adjust them in engrave mode, but I can’t get a quarter rest on the anacrusis.

1 Like

Yes, the rest were overlapping and changing rest pos. in Engrave mode fixed that, but as you say, the quarter rest is impossible to “double”. Why has this been implemented to be so difficult I wonder. I could not find help in the documentation either.
I suggest a FR for D6, where you right-click a rest and get a context menu with “Duplicate rest to voice…”.

Even with force duration on? I think I helped a fellow Dorician last week, inputting explicit rests on a particular boice. Force duration was compulsory.

In the Notation Options do you have “Rests > Bar rests in additional voices > Show bar rests” selected?

If selected forcing the rests with Shift-B “rest” should work:
Aufnahme2

1 Like

There’s another option further down as well, in Rest Positioning, for coincident rests of the same duration; but inputting explicit rests in the upbeat might still be necessary.

I have

and still I manage to get

but not for the first bar.

Changing to the left option gave me

This is no option since I don’t want the “fugue” style in the complete piece, and splitting the piece using flows seems just an ‘academic solution’ to a very simple notation situation that is handled easily in ost notation software, although not in Dorico. I have managed to do ‘double-rests’ before (IIRC), but this time something else must be causing it not to work.

What if you now select the blue rest in the upbeat bar and enter: “6 o , y”? In the following bars you enter Shift-B “rest” in the second (purple) voice.

Nothing.
BTW full bar rests does not have settings like “o”

it is impossible to select Force. For 1/4 rest it works

Maybe it’s a help if I send you my test file?
Multiple voice rests.dorico (915.8 KB)