MultiProcessing / MultiCore Question (for PC)

Hey All,

→ Cubase on my PC is only using 1 core of the 4 cores (and only 1 thread of the 8 possible threads). I’m maxed out on that 1 core and can’t get the others to kick in.

I will admit: I don’t have the latest Cubase; I have Cubase 5.5x. Maybe I need to upgrade? Here’s the issue:

I"ve got a song with only 5 active audio tracks and 1 MIDI track. That’s it.
I’ve put a insert or two on a couple of the tracks.
Nothing more than that.
And I get the dreaded Cubase Popup telling me that my CPU is maxed out. And indeed I start hearing clicks and pops.

Yet, my Task Manager shows the following:

1.) Only 1 of the 8 possible hyperthreads are working. And yes, it’s maxed out. The other 7 are sitting there doing nothing at all. I tried creating new instances of “Reverb” or “Maximizer” or “Compression” for each of the Audio tracks. Still, only 1 processor thread gets assigned to them.

2.) Overall, the CPU utilization is between 3% and 14%. That’s it.
I’m only using maybe 3 Gigs of RAM (out of 16 Gigs total).
The disks are maybe 90% free space. Almost nothing on them yet.

What in the world is going on? I am maxed out on Cubase already? This is unusable.

3.) I know that my I7 CPU does do multiprocessing, because I have a video editor, and when I “Render” a video, the software raises ALL 8 Hyperthreads to almost 100% utilization (each). So the HW of my computer and its BIOS, etc. is apparently set up to do “threading” for sure.

Now here are my HW/SW configuration details:

1.) I’ve got an HP Laptop PC.
2.) I’m using Cubase 5.5x right now
3.) The CPU is an I7 with 4 cores + Hyperthreadeing.
4.) 16 Gig RAM
5.) 7200 RPM disks
6.) Presonus “FireStudio” interface.
7.) Using a Texas Instrument chip set in an “Express Card” so as to enable my PC to connect via Firewire 400 to the Presonus interface.
8.) I"ve checked the boxes for “Multi Processing” and “Disable CPU Energy Saving” and “Adjust for Record Latency” – all in “Device Setup”.

Any help would be greatly appreciated! (Otherwise, I guess I’ll have to look at other DAW software. Ouch!)

Thank you! :slight_smile:

Hey All - just an update to my post.

Thank you to all who responded. (No one, that is.)

Just so as to document my findings on multiprocessing:

1.) I never found a solution to make Cubase 5.5 to actually use multiple CPU cores. Yes, there is a checkbox in Cubase so as to use multiple processors, but in Cubase 5.5 it seems to do nothing at all.

2.) I was not able to get any response from Cubase support (whom I contacted separately from this forum) on the subject of making Cubase 5.5 to operate in multiprocessor mode. I even asked whether the problem could be fixed by my upgrading o the current release of Cubase. No response. (And no response from this User forum, of course.)

3.) As I said in the post, if I couldn’t come up with a “fix” to the problem, “I might have to switch DAW’s”. Well, that’s what I had to do and that’s what I in fact did do. I switched to Pro Tools 11. The end result: the new software does use every core on my machine. It also does use each of the “hyper threads”. No special configuration needed; it does the job straight out of the box with a default installation.

So, problem solved at last. Thank you to all and God bless!

hi djsaustin,

das macht mich wirklich sehr betroffen! :wink: aber vielleicht probierst du es hier: da kann dir bestimmt jemand helfen…andererseits bin ich guter hoffnung, da du dich ja jetzt für eine fehlerfreie daw entschieden hast…