Music Frames Not Cooperating with multiple flows

Good evening all, I’m working on a scale packet for my wife’s studio and this has me starting to pull my hair out.

I’m attaching the file so you can see what I’m talking about. Basically, I’ve created a series of fundamental oboe exercises in a long string of flows (so that I can have clean final bars at the end of each key/exercise). At the end of the original version of the document was the page on long tones. Now she would like me to add in seventh chord and augmented arpeggios before the final page of long tones.

I have gone into engrave mode and adjusted the size of the original frame on that page and added a text frame for the header and a new music frame for the arpeggios (which should begin on the same page that the triad arpeggios ended on).

I originally tried dragging the new blank flows over in Setup mode, but that wasn’t working. Then I noticed that you can filter each frame to only show certain flows, which I tried limiting to the new flows only, thinking that they would all go in this order and then I could rearrange the pages later to move “Long Tones” after wherever arpeggios ended up. But now, any time I try to start inputting pitches it’s simultaneously inputting them on the Arpeggio page where I’m typing them AND on the final page and I can’t seem to get it to stop doing that.

There’s got to be an easier way to add material in the middle of a file…right?
Oboe Scale Patterns.dorico (690.8 KB)

I’m not sure exactly what you tried in setup mode, but I can change the flow order simply by dragging a flow in the bottom panel to a new location.
Alternatively, you can move flows in the Project Info window using the arrow keys at the bottom of the flow list.
Using these methods I could move flows 58 and 59 in your file to be between flows 55 and 56:
Oboe Scale Patterns1.dorico (691.7 KB)

For your own sanity, I’d recommend naming all these flows (e.g. “Major, C” etc) so you can keep track of them.

Alternatively, keep all the scales in the same set in one flow but use codas that you then hide to remove cautionary time signatures etc. You can change the gap shown before codas to 0 in Engraving Options so they’re not indented on new lines.

If you draw in a layout frame to show specific flows there, that won’t prevent them also appearing in the master page frame chain – so you can either keep all the flows in the same frame chain (which is probably perfectly do-able, except for the fact that all your existing page overrides make it a little tricky to follow the changes) or draw these in a separate frame chain, but also remove them from the MA chain. You can also swap page overrides with neighbouring pages, if you want to e.g. push the existing formatting of p9 onto p10.

1 Like

Hi Lillie, sorry I’m just now responding to this, thanks for answering.

I still don’t really understand all of the frame chain stuff, but I’m creating the new exercises in a separate document and she can just input them where she wants them later in Adobe.

I am loving your Coda suggestion though, I wish I had known about that the whole time, that many flows definitely affects the load times.

Question though, I cannot for the life of me find where to remove the Coda indentation in Engraving settings when it’s a new system-- only the number of spaces for a mid system Coda change. Can you point me in the right direction?

Try setting Engraving Options > Repeat Markers > Repeat Sections > Default gap before mid-system coda section to 0 spaces. If you type in the number, you might need to press the Tab key or click the up and down symbols ( and ) before clicking on Apply.

1 Like

The same value applies to all codas, whether they’re at the start of new systems or in the middle of them. You can still use note spacing to adjust gaps locally.

Frame chains can take a bit of getting used to, that’s certainly true, but I’d recommend playing around with a little project and checking/unchecking flows in different places to try out for yourself how it works.