Music XML export tenor voice faulty

The music XML export from Dorico is still faulty for the tenor voice.
This has been the case for some time and has not yet been corrected.
In addition, the position of the crescendo / decrescendo hairpins is also incorrect. The hairpins should be above the stave in the singing parts. The position of the dynamics symbols is correct.

I have analysed the XML file exported by Dorico with an XML editor. My conclusion is that the notes in the tenor part are placed in the wrong (too high) octave. They should be in the same octave as the bass part.
If the notes are placed in the same octave as the bass part, then the transposition for the tenor part in the XML code is not necessary.

Attached are 3 DPF documents with the corresponding information.

I am aware that the Dorico team cannot do everything at once and must prioritize their tasks, but the tenor export is incorrect and should be corrected.

Test XML STTB - Dorico.pdf (79.2 KB)

Test XML STTB - MuseScore.pdf (70.5 KB)

Test XML Export-file-remarks.pdf (1.4 MB)

By the looks of it (especially the fact that the dynamics are on the wrong side) I think a little thing in Setup mode could solve your problem. Click on the tenor’s menu>Change instrument>Tenor (8ve above sounding pitch), how does it look now?
It happens a lot that we need to proceed to a Change instrument>Apparently the same instrument that is already there — because it’s not really already there. That is the same problem than the clefs (one should delete all explicit clefs added by the xml import, unless they’re necessary). Hope it helps.

One thing we can say about Marc is that his tenor voice is definitely not faulty! :grinning:

3 Likes

Thanks for your advise. But it doesnt help. The Tenor I ist set this way that you mentioned by default when you create a new project from a template.
But the result is wrong.
In the XML file you can clearly see the problem.

You need to use the Tenor “Sounds as Written” instrument (with the Notation Options to “Respect ottava clefs”.)

Yes, I do this temporarily for XML export. But that is a workaround and not a solution.

TBH, I use it as my default Tenor voice (mostly because I copy music in C-clefs).

Thank’s Ben, the Tenor problem is solved. :grinning: I didn’t know the parameter “Respect octave indicator” .
But when a project starts from a standard template I didn’t expect to need to make this modifications in the setup.

But the hairpin placement ist still an issue.

Hairpins are above the staff for me.

Can you supply a sample document?

Perhaps check (and alter) the Tenor “instrument” in the Instrument Editor?

Here comes a ZIP-File with the Dorico-, MXML- and MuseScore file.

The workflow was: Dorico → MusicXml → MuseScore.

Both the Dorico file and the XML file have hairpins above the Tenor staves, for me.

The Dorico file is ok. The Dynamics and the hairpins are above. But when I export this file to MusicXml-File and import this in MuseScore 4 or Capella 9 then the hairpins are below.

And in addition here the printed file from Dorico with the correct position of the hairpins.

Sounds like an issue with MuseScore’s XML import, then?

No, I dont think so. It is the same problem with Capella.

And with Sibelius as well.

I think not. Looking at the exported XML, Dorico explicitly places the immediate dynamics above, but not the gradual dynamics.

I agree with you. The direction type for dynamics is set above and correct.
But for the wedge type the direction type is not explizit set. Therefore probably the default position is used and this is below.
I have marked this in the screenshot.


.