MusicXML Import - Wrong Note Lengths. How do I fix this?

Incorrect Notes in MusicXML Import - Dorico

Half of the quarter note import as two tied eighth notes in the score. There are hundreds of them.

How do we fix this, and is there an option to stop Dorico from altering the notes when it imports the files?

The iPad version does this, as well.

Have a look in Preferences > MusicXML Import > Notes and Chords > Note Durations. When this option is checked, “Note durations will match those specified in the MusicXML file exactly, as if they are input using Force Durations.”.

1 Like

I’ll try that. Thanks.

You may want to check Notation Options > Note Grouping, and see that the options there are what you want.

There are also ‘beaming issues’, which if corrected, might help clarify things.

as @benwiggy says, the main thing you want to look at is the relevant patterns within “Note Grouping” and decide which one(s) you want to display as a single note(s). I don’t think, although I could be wrong, that this has anything specifically to do with the MusicXML import.

The difference is the presence of sixteenths rather than eighths surrounding the desired syncopated quarter notes. So far that is just how Dorico rhythmic parsing works unless you use Forced Duration.

Steven Jones’ fix worked. Thanks!

It does, because the option @stevenjones01 described basically applies force duration to every single note on import.

ok, thanks for the clarification --I wasn’t aware of that.

IMO, that should be the default.

IMO the defaults are fine as they are! Different users have different needs.

1 Like

When importing MusicXML, the default is illogical.

The score has already been written. The application should assume the note values in the file are what is intended to be displayed.

I’m talking about i.porting MusicXML.

In no circumstance would I ever want Dorico to not force the duration on any MusicXML file I import into it. I’ve already done that work in the other notation app.

This really has nothing to do with user needs. The default makes no sense. Just turn the option on so everyone doesn’t inevitably have to do it themselves, after wondering why their score is screwed when they import it.

And why, precisely, would that be so? If I’m bringing something into dorico from elsewhere, it’s because I want dorico to make it look nice; I don’t want it to ape another program. The very first thing that I do on every single XML import it’s to select all and then reset everything to its default [according to dorico] appearance and position. Then it’s a clean slate and Dorico’s algorithms can work their magic.

3 Likes

I agree with @Romanos401, I want to apply Dorico defaults to all my XML imports.
Stew

These are your needs, and they are fine, so you have the possibility to set it according to your needs.

Me, too, wouldn’t want to have force duration on every note, because for my needs (mostly arranging/orchestrating) I want to have the flexibility that dorico provides. Also I want the rhythms respelled to the defaults that I select.

If you import your own files, your scenario surely makes sense. But if you receive files from other people… Well, guess I just found a user need different from yours! Isn’t that amazing, how our own mind is so incredibly fixated on our own “needs”?

2 Likes

Because when I wrote the score, in whatever application I exported it from, I input a quarter note… not two tied eighth notes.

If I wanted two tied eighth notes, I would have written it that way myself.

If they don’t want to change the defaults, then they should prompt the me before import whether I would like to force the durations notated by the composer in the score. With a box “do not ask again,” like many other software products.

The software exists to work for me, not vice versa. When I import a score, I don’t think it’s a reasonable expectation that the software changes tons of notes in the score. Dorico was the only software that did this. I tried multiple, because I initially thought the export was the problem.

In fact, I noticed this months ago and simply decided to not use the software “yet,” because I didn’t feel like dealing with it at that time.