Muting an intrument track mutes the MIDI?

Hi all,

I note that muting an Instrument Track now mutes the MIDI being routed the VST. Is this a recent change? I can’t recall this happening with Cubase 6. Previously, I could mute an Instrument Track and the MIDI would still be routed to the VST intrument, as it was only the sound of the VST that was being muted.

Is there an option you can change to reset it back to the way it was in Cubase 6? The reason I ask is because I have projects where I have designed a sequence/arp triggered with MIDI events early in a project and then I un-mute them later in the project. With the mute function running as it does, it’s missing all of that info and un-muting later in the project drastically changes the track (i.e, a held note is started from the point at which it is unmuted, which completely screws with long step sequences in synth VSTs, for example).

I could go back and edit the volume separately as automation, but it’s far easier to hit mute than it is to manipulate faders.

Is there a way to change this back to the way it was before?

Change the Chase Event Filter.

That doesn’t work for note data - it’s still not fed to the instrument if it’s muted.

These are my chase events options right now.

Anything wrong?

Maybe I’m not getting it, but what if you un-check note?

If not, why can’t you use a MIDI track?

Nope, doesn’t help. Notes which have already started to be held simply aren’t picked up if you unmute them with the filter unchecked.

I could use MIDI tracks, you’re right, but for all of my already created projects in Cubase 6, this completely screws them. It also completely negates the advantages of instrument tracks.

I honestly have no idea why Steinberg thought it would be a good idea to do this. Perhaps because we can’t bypass VSTs in instrument tracks in the same way we can when they’re loaded separately, and hence it’s a ‘cheap’ way to save performance?

I am not sure that I know what would cause your situation to arise.

However, I created an Instrument Track using Groove Agent ONE with an instance of the MIDI Monitor on MIDI Insert i1 on the track. I then played on an external keyboard to view the MIDI Events in both plugins which worked, and even when mute is activated I can still see the events showing up in the MIDI Monitor (adds the events to the list) as well as in GA1 (there is a little red “light” to the left of the program name that blinks), though I can no longer hear the drum sounds that correspond to the keys I am playing.

  1. Create an instrument track with a VST synth with an inbuilt step sequencer. For my testing, I was using Arturia’s Modular V.

  2. Create a MIDI event about 8 bars long, with one note (intended to trigger the sequence) held throughout the entirety of the event.

  3. Play from the start of the 8 bars. The sequence should start from the beginning (i.e. the VST should be receiving MIDI data). You will see a ‘Note On’ value captured if you’re using a MIDI monitor insert. This is all fine.

  4. About 2 bars in, mute the instrument track. Keep the VST window open. You’ll see the sequence stop. This means that the VST is no longer receiving MIDI.

  5. Un-mute the track. The sequence will now start again from the beginning, and you will see a fresh ‘Note On’ value captured in the MIDI monitor.

Imagine you have a long, sustained MIDI note for a drone, which you mute and then un-mute. You’re effectively playing the note again. This did not happen previously - the VST received the MIDI event regardless of whether the track was muted or not. This does not happen now.

And Elektrobolt - record that track and play it back while muted. I guarantee that the MIDI monitor will show no events being received. Then un-mute the track and play it again. Watch what happens.

I guess you should be able to choose between modes. One workaround would be to assign the instrument output to a group track and use that for muting. I myself prefer the versatility of midi tracks and the vsti rack.

I note that muting an Instrument Track now mutes the MIDI being routed the VST. Is this a recent change?

Not really. An Instrument Track has behaved this way as far back as C5…probably earlier. Muting an Instrument Track has always cut both MIDI data and audio simultaneously. Incidentally, muting, by using the Mute Tool on a Instrument Track’s Part, will Mute MIDI only. If the Part is one big whole note, the track will play out the arpeggiation until the Part’s right border is reached.

  1. Un-mute the track. The sequence will now start again from the beginning, and you will see a fresh ‘Note On’ value captured in the MIDI monitor.

This would be caused by having “Note” checked in the MIDI Chase preferences. Uncheck it and the arpeggiation will not restart until the loopback to the L marker.

The behavior you want only works with a MIDI Track tied to a VSTi in the Instrument Rack. This is the only situation where MIDI muting and audio muting can be separated as a “pre-planned” solution. Dr.Lupo’s suggestion to Group the track(s) and mute from there, is the best workaround if you’ve painted yourself into a corner with the Instrument Track’s dual muting behavior.

After reading this thread from the top, I can only draw the conclusion that you are remembering MIDI Track/VST Instrument Rack behavior as MIDI Instrument Track behavior. It happens.

I… I’m mistaken.

There really is nothing worse than someone who doesn’t check their facts, especially when complaining about something. I’ve just gone back and reinstalled Cubase 6. It’s exactly the same as it is in 7. Just imagine the look on my face. What possessed me to make such a tit of myself?

My profuse apologies to everyone. I was wrong. Mea culpa!

Who cares? Everyone love tits. :wink: