Muting of instrument tracks


I’ve noticed that muting instrument tracks and IAA instrument tracks, only seems to mute the audio, while the instrument plays on in the background. I’m not sure this is the best choice on a resource challenged platform like the iPad.

Someone (like me) might very easily mute a bunch of tracks, believing they had just freed up resources, when in fact this is not the case.

Reproduce by adding a bunch of Nanologue tracks, punishing the CPU a bit. The mute all but one and watch as the CPU meter does not go down.


Hi Nenox,

The freeze function has been introduced to save CPU.
Please make use of the “Unfreeze Deletes Audio Track” option located in Setup/Arranger, if applicable.


Thanks Lars,

To me mute and freeze are very different animals and are used for different purposes in different workflows.

I will freeze a track when I want to keep it/lock it down or when I simply want to listen to it, but need to free up resources. In both cases I want to hear the track I’m freezing.

I will mute a track when I don’t want to hear the track I’m muting. If I’m doing multiple takes of the same part, trying a different direction or just to shelve some idea or stuff for later. Here I expect mute to allow me to do that and not worry about it, but your implementation of mute does not let me do that (resources).

Having to freeze, in order to mute, sounds like a pretty strange workflow to me, unless we are talking about a work around, for lack of better, in which case it makes prefect sense.


Hi Nenox,

As the name implies, the mute function has been designed to do exactly that, muting the playback of tracks.
It is not possible to free up resources (e.g. unload an external instrument inserted via IAA) via mute.

To free up CPU resources (caused by internal and/or external effects or instruments) please freeze the tracks and unload inserted instruments.


Hi Lars,

Any overhead of having an instrument instance on a track is acceptable IMO. But I’m taking about the fact that notes in parts are still playing when a track is muted.

Make a Micrologue track, set the polyphony to 10 and make a part the plays all 10 notes.
Now create two additional Micrologue tracks and copy the part from track one, onto these.
Playback should now overload the CPU or tax it heavily.
Mute all three tracks and press play.
Note that the load on the CPU has not changed (because the notes are still being played).

Only workarounds seems to be:

  1. Freeze all tracks, then mute the frozen audio tracks.
  2. Mute all parts of the track.

Both are laborious and non-intuitive and you have to realize what’s going on, in order to even consider them.

I don’t know about you guys, but I think this is an issue.

P.S. For IAA instruments things are slightly better. Here just setup the IAA instrument on an Audio track and put any nodes on additional MIDI tracks (that you route to the IAA instrument). This also get’s around some other nasties with Instruments tracks.

Hi Nenox,

Again muting an instrument track does not result in disabling (or unloading) assigned instruments.
Freeze is the way to go instead.

To give you another explanation:
Mute/solo are functions where instant feedback is expected and required (e.g. mute the bass track for a second, unmute afterwards). Combining mute with unloading/reloading instruments would result in a tremendous slow down.


Many thanks Lars,

But I’m not asking for instrument to be unloaded/disabled.

I’m asking for MIDI notes to be muted along with the audio output of the instrument, so they are not stealing resources in the background.

This would of course mean, that any notes played while the track is muted, will not be heard when un-muting the track. This would be the behavior I expect from a MIDI track anyway.

If I want to be able to mute/un-mute freely, without notes getting cut off, I’ll mix it down to Audio (or freeze) first. This in turn will give me the muting behavior I expect from an Audio Track.

Simple, transparent and resource friendly :slight_smile:

Anyhow, I’m going to try this in Cubase, to see what the behavior is. Maybe I’m just way of the mark here!



Behavior in Cubase AI is as expected, which means not in line with Cubasis behavior.

Note that I don’t expect Cubasis to be Cubase . I’m just opposed to re-inventing the wheel, when the existing wheel formula arguably would have driven better and would have been more suited for the iOS road.