My Cubase Elements 10 Don't works

I installed a cubase elements 10 in my PC Windows 7 - 64 bits system. And in the moment that i tried to open, i just can see the main screen where the software load, after that don’t pass anything. I take a look on the task mannager of windows and there’s just a “VST scanner” process but i can’t run cubase. I don’t know.

Here’s my PC Specifications. I’ll be thankful for a solution, i spend some money in this program.

Screen Resolution: 1280 x 720 p 60Hz
Processor: AMD A4-5300 APU with Radeon HD Graphics 3.40 GHz
Windows Ultimate 7 64 Bits - Service Pack 1

Hi and welcome,

It seems some plug-in is not really compatible. Do you use any 3rd party plug-in? Make sure the plug-ins are up to date, please.

If it doesn’t help, try to start Cubase in Cubase Safe Start Mode.

I don’t have any plugin in the VstPlugins folder. I tried with the Safe Start Mode, but still don’t works. Just the same main screen.


There was another user with exactly the same issue. As far as I remember, he just removed the vstscanner component. Then Cubase started and worked.

At your own risk. :wink: