My experience upgrading to 4.0 (activation pending)

I thought I’d made it through all the hoops, but when I tried to enter the activation code, I got this

I uninstalled and reinstalled it a few times, only to have the same error.
I then discovered there’s yet another application called the Activation Manager (why are there so many pieces of separate software for this one thing??) and it was empty. No products, activated or not.
I searched the forum and found this thread that suggested entering the code into the download assistant, so I put it into the “download access code” since I didn’t know where else to put it. Initially this seemed promising because it seemed to be accepted, but then I got this:

On a whim I decided to open up the Activation manager again and suddenly Dorico 4 was there, so I put in the code, and now it says Verification Pending.
I tried opening up the elicenser again, but got the same “old version” error again.
I see in this thread that something is still wrong. What should I do?
Thanks in advance.

I never had to “old version” error but I remember getting the “no license message”. I uninstalled e-licenser and reinstalled it and that worked for me.

You might have to repair your Soft eLicenser in the maintenance menu of eLicenser. I can see it is grey with a no-smoking symbol overlaid, probably indicating some kind of corruption.

I ran the maintenance several times - no luck.
I’ve submitted a ticket (sounds like filling out a form, but is actually sending an email) and the support person is getting me a new code to put in the Download Assistant. I’ve already downloaded and installed it (and am using it), so that seems strange, but ok. :person_shrugging:

What does the Dorico licence look like in eLCC?

Could you try following the steps outlined here: (click on the option that says “Steinberg Licensing” on that page).

Thanks to everyone for their suggestions.
The representative got back to me with a new code to put into the download assistant. I think that worked - the activation manager says it’s activated and no longer pending.
I hope this upgrade process gets streamlined in the future. This was an unintuitive process to say the least.