My mixer doesn't work

Generally I don’t use the mixer, but when I do, it doesn’t seem work: moving the volume control up or down on any instrument has no effect on its volume (in Write or Play mode) – even at zero level. Am I doing something wrong? Is there an on–off switch or some other setting I’m not noticing? Have I done something to put it in a strange state.


What playback devices are you using, Norm? Are you using the default HALion Symphonic Orchestra sounds, or something else? Make sure that you don’t have the MIDI faders shown by accident: you need the VST faders to affect the output level from HSO.

This is very confusing to me, Daniel.

  1. I use the default HALion Sonic SE (HSSE) sounds. I have no MIDi source unless Dorico has provided one.
  2. The piece I’m working on has 20 instruments (so far). The trumpets happen to be the top staves and so show up in the HSSE source display as 1 Trumpet Combi, 2 Trumpet Combi, etc. But when I bring up the Mixer display, they show up as labeled HSSE 9 Trumpet, etc, proceeded by a list of 16 + 8 unlabelled HSSE faders. The HSSE 9 Trumpet fader has no effect on volume; unlabelled HSSE 9 fader does change the Trumpet 1 volume. When I activate the next HSSE source icon in Play mode, the instrument staves near the bottom of the score show up…but the trumpets do also show up in different positions. The Mixer then shows even more unlabelled HSSE faders, and I have to look among the unlabelled ones for those that control the various instrument volumes. In the Mixer, the HSSE faders labelled with instrument names (and position numbers that seem arbitrary) have no effect.

In short, I’ve no idea what’s going on, Mixer-wise.


If you do Play > Playback Template and choose to re-apply the default ‘HSSE+HSO (Pro)’ playback template, which will reset everything HSSE-related, do things make any more sense?

Daniel, when I do Play > Playback Template and choose the default ‘HSSE+HSO (Pro)’ playback template (which is already highlighted), the ordering of instruments in the Mixer is changed; but only the HSSE 1 Trumpet fader “works” and it changes ALL the instrument volumes.


In regards to the ‘fader’, the internal routing of HSSE is set up wrongly. Please open the HSSE editor window and in there change to the MIX tab. On the right side you see the output routing for each slot. With you it reads “Main” for every slot, but the second slot must route to “Out 2” and accordingly the other slots up to “Out 16”.

The channels in HALion Sonic SE should automatically be mapped to the correct audio outputs. I think the only way they could be set otherwise is if you have somehow overwritten the default HSSE configuration.

If you have saved the default state of HSSE on your computer, the default data file will be in %APPDATA%/Steinberg/HALion Sonic SE_64 (Windows) or ~/Library/Preferences/HALion Sonic SE (Mac). I can’t remember off the top of my head what the file will be called, but hopefully it’ll be reasonably obvious. It should be safe to delete that file, and then when you apply the ‘HSSE+HSO (Pro)’ playback template again, hopefully Dorico will assert the correct default setup for HSSE with each of the channels routed to a separate output.

Daniel, at the Windows location you specified, Halion Sonic SE_64, I have 4 files that refer to “Defaults”: ContentManager.xml (129 KB), Defaults.xml (11 KB), MediaDefaults.xml (20 KB) and MediaFactoryDefaults.xml (20 KB). They all seem to have the same kind of gobbletygook code in them, so I’m reluctant to delete any without more info. (Neither of the ones with “Default” in their title refer to specific instruments, near as I can tell.) And you said “It should be safe to delete that file.” Well, what if it isn’t. Then would I have to re-install Dorico?

In regard to Paul’s comment, I don’t think I did anything strange. The piece I started with was for brass quintet, which I was subsequently asked to expand to concert band; so I’ve been adding band instruments a few at a time, now up to about 25. It is strange, however, that while the first 16 show up in score order in the first HALion Sonic window, the second HALion Sonic window shows 16 instruments including ones already in the first list, but all in a seemingly random order. Does this suggest something’s not working right?


Then simply rename the folder “HALion Sonic SE_64” to something like “HALion Sonic SE_64 backup”. On the next startup HALion will automatically create a new folder “HALion Sonic SE_64” and fill with content. If you experience any problem, you can then still revert to the backup.

Once you’ve done as Ulf suggests, then you will need to re-apply the HSSE+HSO playback template in Play mode, which should create new instances of Halion Sonic SE with the correct channel routing.

The haphazard order of instruments in HALion is intentional. See my post here for the rationale behind this: (in summary, it’s to ensure that Dorico doesn’t overwrite any sound changes you’ve made yourself)

I’ve done as recommended by Ulf and Paul to no effect; only the very first (left-most) fader works in the Mixer, and applies to ALL the instruments.

So I constructed an entirely new project consisting of a mix of 21 parts among various brass, woodwind, and percussion sounds–and a measely 1 bar in length. The 21 instruments (all chosen as Solo Player) were loaded in the two HALion Sonic editors, with no repetitions showing up, and they all play as expected. And all 21 instruments show up–with labels (Trumpet, Clarinet, etc.)–in the Mixer. BUT only the left-most Mixer fader “works” and applies to ALL instruments at once–as before!

Would not this behavior suggest a problem with the Mixer rather than HALion Sonic–or the connection between them? Or since apparently nobody else has reported this problem, does it point to something wrong with my Dorico Pro installation? Or am I just doing something stupid? (I can’t imagine a simpler test than the one I just described.)


P.P.S. Ulf’s first suggestion to me was to select the Mix tab in the HALsion Sonic editer and assign each instrument to a specific channel (Main, 1, 2, … 15). This does work, sort of. First, the Mixer doesn’t show which channel is applied to each instrument-labelled fader, so some trial and error guess work is required; second, this only allows 16 channel specifications, so in the the second HALsion Sonic editer, there’s no place to go. In any case, it strikes me as ridiculus that we would need to go through that kind of preperation for a function that should be transparent with regard to a single source of instrument samples (as in another music program I could mention).

Yes, the point we’ve been trying to make is that by default Dorico does send a specific configuration to HSSE when it instantiates it that has the routing on the Mix tab in the HSSE interface set up appropriately, i.e. with each channel pointing to a separate output. For whatever reason this isn’t working on your computer.

I would suggest downloading the full ‘Dorico 2 Pro’ installer and the full ‘Dorico Playback 1 - HALion Sonic SE 3’ installers from Steinberg Download Assistant, and run them both (quit Dorico first, of course). Perhaps the problem is simply that you’re using HSSE2 and you need to update to HSSE3.

Almost there…
I took Daniel’s suggestion, downloading the full ‘Dorico 2 Pro’ installer and the full ‘Dorico Playback 1 - HALion Sonic SE 3’ installers from Steinberg Download Assistant. (It took a bit of time since I’ve a slow DSL internet connnection.)

  1. In re-installing ‘Dorico Playback 1’ I got a message that there was an incompatiblity between Dorico 2.1 and 2.2, so evidently the 2.2 upgrade left some “dirt” behind in the 2.1 projects. The installer also said that I already had HALion 3 installed, but I re-installed it anyway.
  2. After re-installation my reported Mixer problems remained for projects begun in 2.1…until I clicked on the HALion option in Play>Playback Template, which re-loaded the sounds. (I had clicked on this before re-installation with no effect.)
  3. The Mixer faders now work fine for the older projects…but for more than 16 instruments the instrument order in the Mixer is more or less random relative to score ordee. (So there still seemes to be some left-over incompatibility.) I can live with that, but it would be nice if the fader order could be changed to match score order, automatically or by moving individual fader locations. Re-invoking the Playback Template command or clicking on Play>Reset Playback Overrides has no visible effect on the order.


P.S. Is there an easy way to “paste” a large older project into a new one, such that the result would be a really clean 2.2?

I’m glad that you’re basically back on an even keel now. I’m not 100% sure whether you can guarantee that the order of the faders will match the score order at the moment, as I’m not sure whether Dorico uses the internal identifiers for the players (which will be based on their order of creation rather than their order in the list) or their score order to determine the order in which sounds are loaded when applying the default playback template.