My VST instrument on the timpani trackwas changed to acoustic grand piano

I am using the Halton sonic lab VST instrument on my project. There are many tracks, two being Timpani and snare drum. The timpani track, without me doing anything, has defaulted to the acoustic grand piano and I cannot change it to the the sound it was on (it was something like studio snare. I can’t remember). usually if I choose an instrument form the Halton library I have soooo many options, but for this one track, that had all those options at one point, has randomly limited me to a few options. I cannot undo this and it seems to happen randomly to other tracks. How can I get back to the large selection again? why has it defaulted to piano? am I changing the instrument correctly? these tracks are imported from a midi file, if that helps.

also I can’t screen shot and show my issue. Thanks Windows smh. actually just technology in general smh.

It looks like a “program change” problem…
2 solutions i think :
deactivate receiving GM or prog change in your vst’i
or empty the right case in the track inspector

or trash prog change of the midi tracks thru list or key editor