Mystic / Spector don't sound right after first loading...

Mystic and Spector don’t work anymore correctly (at least this never happened in Cubase 8.5 Pro).

  • Make a new empty project.
  • Record a short track with either Mystic or Spector.
  • Save the project, close it and open the project again.
  • Play the track and it will sound so horrible that you think it may damage your speaker!
  • Reload the instrument and it will sound fine.
  • After next reopening of the project the bug will appear again.

Interestingly these problems don’t happen with any third party plug-in but only with Steinbergs own Mystic or Spector (and maybe some others I haven’t tried…)!

Cubase 9 Pro
Project-settings: 48 kHz / 24 Bit
Windows 10 Home 64 Bit
Intel Core i7-6700K CPU @ 4.00 GHz
RAM: 32 GB

Regards, Konrad

1 Like

I have the same problem over several versions of Cubase and involving 2 different computers. I have notes so that when I open a project with Spector I am reminded to change and then reload the correct instrument for each instance in the mix. I am surprised more people have not commented on this bug.

Currently using C 9 Pro, Win 10 Pro 64bit., Intel i7-7700 3.6 Ghz

1 Like

I tried it with mystic in a non-empty project, and it seemed OK. But I did not quit Cubase, just saved/closed/opened.

Is it loud? if it is it might be related to this Spector reloads extremely loud. - Cubase - Steinberg Forums

I’m not noticing any problems. I didn’t find the spector being too loud problem, but maybe I didn’t exactly duplicate the steps required to make it happen. I’ve never been big on the media rack.

This has been happening to me ever since I updated to 8.5. The sound would become very harsh and metallic randomly. I have to load up the sound again to get it to reset. I tried freezing the instrument but to no avail. Maybe the best solution would be to render it or to just avoid using it. These vsts have not had an update in a long while or maybe ever :roll_eyes:

I’m having the same issue.

I’m a newbie at Cubase and was working on my first actual session a couple of days ago when this happened. I was running Cubase Pro 8.5.30 on macOS Sierra 10.12.6. So I thought to myself, maybe they fixed this in Cubase 9.5… So that gave me the final push to make a clean install of my Mac and try Cubase Pro 9.5, that way maybe I’d buy the upgrade at the end of the trial, but this time I’m running it (9.5.10) on Mavericks 10.9.5 which is unsupported, but it seemed that many people running Cubase 9.0 were having less issues on Mavericks to begin with, and Mavericks is just much faster than the newer OSs.

Results: It’s happening in Cubase 9.5.10 as well.

Since I’m using presets, I found that simply re-choosing the presets corrected the issue (instead of completely removing the instrument from the slot).

Apparently this doesn’t affect Prologue. It does affect Spector a little bit but Mystic a lot! Like the OP said, something that seems like it would ruin your monitors.

Funny, I try to move to Cubase after getting aggressive loud noises with Pro Tools 12.8.3, only to get these issues with Cubase now…

Is it possible that Steinberg hasn’t noticed this issue yet even though it’s present in Cubase 8.5, 9 and 9.5???

UPDATE: I completely uninstalled Cubase Pro 9.5 (even removed the receipts) and installed Cubase Pro 8. The issue is present there as well.

Honestly, is it possible that Steinberg actually missed this, or even worse, don’t even want to fix it??

These synths are very underrated. But at the moment they are unreliable because of this bug so i dont use them all that much. Actually…the synths didnt seem to have this bug in cubase 5.5. But i made a big jump to 8.5 over a year ago (and now 9.5) and the synths have not been right since jumping to 8.5/9.5

yes i having the same issue on 9.53.

I just came across this thread… Same Problem with Spector in Cubase 10.15. As I tweaked a Spector patch without saving it as a user-preset, reloading it was not an option for me. I closed and reopened the project, an Spector works as expected again.

Same issue. Using Cubase 11!
A. Why put all that effort into making a synth and then letting one bug render it completely useless, and
B. How has this not been fixed yet? In over 5 years?

Cubase does a lot of things right, but stuff like this and not just having a “humanize” function for quantizing drums (“no problem, just spend days doing it manually!”) is what makes me think of switching DAW’s. At least there’s sidechaining now.


I’d assumed that there was something wrong with the way I was using these synths - at first I thought it was just one sound I was using, and I tried all sorts of things in an attempt to fix it. Sorry to discover that it’s a bug that has been reported at least since 2016

It’s a shame, because I have found a few sounds I like, but in this state it’s unusable.

Cubase Pro 11.0.4
Mac OS 11.6

Yeah, this bug has been around forever. A workaround is to load your project, then select a different patch for Mystic/Spector than the one you need, and then select the one you need right after that. That (most of the time) fixes this for me. For the Steinberg programmers - this seems to be an initialization bug, where some [state] variables are either uninitialized, or aren’t initialized to the same values when you load the instrument. My guess would be that the phase of the oscillators isn’t [re-]initialized properly. I hope this makes it into a future bug fix!