N10.3 - UAD plugins not working in insert slots


after updating to 10.3 i have a weird problem - when i use a UAD plugin as insert on an audio or instrument track the plugin loads but is immediately deactivated (activate button greyed out, routing also greyed out). And it is even not possible to delete the plug in directly (only with some tricks). When i use the UAD plugs in a fx channel, everything works fine - seems to me like a bug in N10.3 (in N8.3 everything works fine)

Or is there anything to change in the preferences?

Otherwise please give us a quick 10.3.1 update (i have found other bugs also but these are not so big as the problem with UAD plugins).

(Work on Mac OS X 10.14)

Thanks for help.



after more research i found the solution myself: it is the “delay compensation”-function in N10.3. But it seems to turn off only my UAD plugins, most of the other plugins (VST2 and 3) work with or without delay comp.

BUT: in N8.3 the UAD plugs worked in the insert slot of audio or instrument tracks regardless of the delay compensation status (on or off, in both cases it worked).

Is this really a feature or just a bug? Would prefer the way it worked in N8.3


Hello cubass…
UAD plugs work fine, here, on 2 PCs.
UAD-2 QUAD, delay comp. in or out, Win 10.
Hope, you get it fixed, soon.

Servus, Big K