N10.3 - Waves - Win10 2004 - Loading Issues

Hello together,
after Updating our Win10 Operating Systems of two of our machines to Win10 2004 I am experiencing a significant increase in loading times of (especially) Waves Plugins. Nuendo Plugs load fine and as it seems to be any other brand also.
I am posting this in the Waves Forums also, but would like to know if anybody experiences anything simmilar.

Also I know, that in the compatibility list of N10.3, 2004 is not listed.
I am not complaining, just asking for similar experiences and if so, what might have helped overcome this issue.

Loadingtimes of one Plugin sometimes goes up to a minute. When loading a session with several Waves Plugins it sometimes takes up to 10 Minutes.

As off now I am getting rid of all Waves plugins and replace everything with Stock Plugins. Some can’t be replaces like the WNS or W43. These together with the L2 are my biggest concerns.
Waves Plugins are also up to date (V11)


I’m on win10 2004 with waves v11 up to date and all the plugins load instantly - without any noticible delay.

maybe something has changed in waves security accessing licences on win10 2004 for you?
I have my Waves licences on USB drive.


Good to know that it actually “can” work :slight_smile:

hm, thats where I got them, too.

Actually I noticed also, that the system has a hard time loading the Pool (even with emty projects) or the Preset Window. I noticed that actually just now. Maybe the issue is related?

if so - maybe there is something blocking Nuendo accesing file system. don’t know if microsoft did some change in 2004 but I would start with temporary disabling firewall and antivirus software

Hm, I tested a lot of things, like Win Defender on & off, Firewall Settings etc.
Can’t see any positive results. Also what I noticed is that when a Waves Plugins loads everything else seems to freeze up somewhat. Like dragging a Tab in Firefox suddenly freezes and jumps to its position after the Plugin finished loading. Very strange behavior.
Any more ideas?
Here are my specs on one of the machines:

OS: Win 10 Pro 2004
Mainboard: Supermicro X10SRi-F with Intel C612 Chipset
CPU: Intel Xeon E5-1660 v4
GPU: NVIDIA Quadro M4000
SSD: Samsung 860 Pro
Audio: Yamaha AIC-128
Video: Blackmagic DeckLing 4K Extreme 12G

Really hitting a wall here.

strange indeed. just an idea:
Waves plugins are different form most of other because they reach licence on USB drive.
If the whole system freezes maybe it’s because Waves is accesing that stick and messes something up with usb controller driver (it not only access licence files but also that USB drive serial number).
I would start with opening Waves plugin outside of Nuendo (in Reaper for example) to check if happens there too.
then maybe updating USB port drivers?
moving Waves licences to another USB drive?
change USB port?


Good idea trying a different DAW.
Just tried Pro Tools on the same machine.
There the Plugins open up instantly. So it must be some kind of awkward Nuendo thingy.

Gonna try rebuilding Configs (again) and see if that changes anything.

Hm, resetting Configs might have helped a lot.
I have to check if in all circumstances and why, but looking actually pretty good so far.

So tripple post here, but I had an “heureka” moment yesterday regarding this issue and I wanted to share for others who are experiencing similar things.

So the problem is not “only” Waves, but it is part of the problem, mainly because of the Licenses on a USB stick.
Nuendo also momentarily froze when loading Trackpresets, opening the pool, and doing similar things where it had to use or read somekind of file somewhere in the system outside of the Nuendo folders. So that got me thinking and kamil certainly pointed in the right direction!

The problem was not the USB stick messing with something, but it actually was something blocking Nuendo accessing the filesystem.

Actually I had 3 Networkdrives connected to the other studios to be able to easily sync up keycommands and configs throughout the rooms. When all the rooms were turned on I did not have any problems, but it came back the next morning when only this one studio was running. So Nuendo is actually checking the networkdrives while checking for Waves Licenses or while opening a preset etc. but can’t be reached and the system freezes until some sort of timeout by the OS, that the drive is not reachable.
The solution was to remove the networkdrives which are potentionally “not connected” at any given time and I solved the syncing in a different way.

I am so happy to have solved this problem and the system now runs smooth an fast.

Thanks again kamil to have pointed me in the right direction.

I’m glad you figured it out. Sounds like a tricky issue. Great job finding it!