N12 & Cubase 8.5 wont work together

I originally had cubase 6.5 & yamaha n12 working on windows 764bit on my old computer.
I bought cubase 8.5 and installed it for the first time on my new computer, and downloaded the following and installed them:
ssdm200w, and
for some reason, the n12 still wont work. the computer is showing its connected, but when opening cubase, the cubase ready light is not coming on, even though it says its connected in cubases device setup pages.
also, i tried using it as a soundcard in FL studio, and in native instruments traktor 2, and it wont work with those either.
my new computer is:
AMD A10-6800k APU with Radeon ™ HD Graphics 4.10GHz,
32GB Ram,
Windows 7 64bit. (im not sure if you need more info).
strangely enough, despite the desk being connected by firewire, and i am able to update the desks firmware through the cable, it just wont work using audio. in any way, shape or form. it wont recieve audio from my internet browser on sites like youtube (not a single website will allow the desk to play audio, this isnt restricted to certain websites)
This is really annoying, as i may have to just go back to cubase 6.5 and get rid of my cubase 8.5
please help if you can, it seemed like setting up the n12 with cubase 6.5 was a walk in the park, and i really have no clue what i need to do. i was sceptical trying to use cubase 8.5 with my n12 desk, and this is the exact sort of nightmare i have been worried about.
Kind regards


Actually it’s most likely not a Cubase 8.5 issue because my n12 runs fine on 8.5.

Before going with 8.5 I had been running Cubase 4 on an XP machine and was scared to death to update. I hate messing around with drivers and firmware etc. There is a large n12 thread over at GS and I had been pretty involved in it early on when n12 was released. I read through post’s about people doing updates and one thing that became very apparent was you had to do the updates in an exact order. When the day came for me to update I read the install directions 3 times, even printed them out and had them right there to make sure I did it in the right sequence. It was scary but it worked. This whole process is absurd and there were horror stories over at GS. I’m curious why did you have to update the firmware if you were already runnign 64 bit OS? I think something went wrong in the installation process. In that process you will get a prompt that the installation (firmware) went OK, did you get that? I remember mine sort of hanged on that and I was real worried…but it worked. Have you tried to reinstall the driver? I would also post this over t GS, number of users over there too. And just to say you should maybe post this here under the Computer/Studio hardware forum here.