N6.5 Abbey Road Plugins Problem

Has anyone else had a problem with N6.5 and the Abbey Road Plugins (particularly the TG12413 Limiter)?

It won’t load it and when setting the plugins path, soon as it sees it N6.5 quits!



Loads fine here. TG12413 v2.0.1. What version plug-in are you using?

Just updated all of the Abbey Road Installers - now it won’t get passed the boot up icon, stopping at RS 127

Nuendo 6 works just fine!

OK, re installed all the Abbey road plugins (from the Abbey Road Legacy site) and Nuendo 6.5 boots up.

any project with an Abbey road plugin will load right up to the channel with the plug in then quits.

I have tried resetting the path under devices / plug in information / VST 2 x Plug-In Paths, and Update, and Update Plug-in Information, all result in Nuendo quitting when any Abbey Road Plugin in checked.

I would get rid of the Abbey road plugins, but I run a commercial studio in which I have MANY projects with those plugins not finished yet.


Back to Nuendo 6 for me (what a waste of £80!)

Relax, take a deep breath, it will come around.

Finish your client projects in the version they are at.

You have just learned the cardinal rule nr. 1 of DAW’s - NEVER update/upgrade in the middle of projects.

In a commersial studio it would be wise to set up a test computer or two. I have set up three test computers atm.
Running both Windows 7 and Windows 8/8.1.

Test, test , test, and NEVER be the “first man out”. Let the others be your Charlie testers :wink:

Thanks for the kind words

My problem is that I am ALWAYS in the middle of a project, so really I’d never update Nuendo and I’d still be on version 4 on which I started. I have kept every version of Nuendo since 5 for this reason, and I certainly wouldn’t delete version 6 to make way for 6.5!

No, my beef is with plugin compatibility issues, I have had feedback form another forum mate (on a separate post) that his Abbey Road plugins work fine with 6.5. All I want to know is, why mine DON’T!

Any help is appreciated!

Sorry, can offer no further suggestions. As I mentioned above Abbey Road TG12413 works fine here. Can’t imagine why they don’t work for you. The wonders of plug-in compatibility!

You didn’t mention the precise version number you are using.


Did you try rolling back to version 2.0.1?