Name in Instrument Picker

Screenshot 2023-11-16 at 1.29.46 PM
Somehow, some of my instrument names have been thrown off. How can I change “Clarinet in Bb 1” back to just “Clarinet” with variant “B Flat”?

1 Like

Is it possible that you’ve overridden the instrument name in Setup mode? In the Players panel in Setup mode, expand the card for the player holding the clarinet instrument, and bring up the context menu for the instrument card. Choose Edit Names and in the dialog that appears, click Reset to Default.

Reset to Default does nothing when I click it. You’ll notice that it says “Editing Instrument: Clarinet in Bb 1” when it should just say “Clarinet”.

Perhaps you could attach the project itself? You can delete all the music from the project before you attach it here, e.g. by creating a new flow and deleting the original one, if you’re worried about sharing the project.

If not attaching (which you should), what are your staff label/transposition settings in Layout Options?

Marching Band Template.dorico (2.1 MB)

The stall label/transposition options are irrelevant here. The fundamental name of the instrument has been messed up, and it is impossible to change it.

Thanks for attaching the project. As I suspected, you have indeed edited the name of the clarinet instrument. In Setup mode, I opened the Edit Instrument Names dialog for each of the clarinets in clicked Reset to Default, then went to Library > Instruments and found that the clarinet now appears as Clarinet (B flat) (in score).

If it’s important to you that the short name for the clarinets is C rather than Cl. then of course you should edit the names, as you have done, and there’s no real harm in how the instrument appears in the list in Library > Instruments.

When I do that on my computer, nothing happens. I’m not dumb, I had already tried that a dozen different ways. This also messes up the instrument numbering- when I create a new clarinet I have to manually fix the numbering. I don’t think the defaults in my copy of Dorico are correct, and I cannot figure out how to change them.

I’m certainly not accusing you of being dumb. Please do Help > Create Diagnostic Report and attach the resulting zip file here. Your user library must have this clarinet name override as a saved default. I can selectively remove it for you.

Dorico Diagnostics.zip (728.9 KB)
Where can I access/change the name overrides?

userlibrary.zip (5.9 KB)

The attached zip file contains a single file called userlibrary.xml. Copy this into /Users/yourusername/Library/Application Support/Steinberg/Dorico 5, overwriting the existing file in that location, and your default clarinet instrument name will be restored to its factory default.

Can a surmise that this is not fixable within Dorico itself then? I’m willing to manually edit the XML file if that’s necessary, but I’m mainly looking to learn how to competently use Dorico myself. Is editing the XML file the current solution to this issue?

I’ve followed your directions. After hitting “Reset to Default” the incorrect name still appeared, at the top left of the Edit Instrument Names window, but after closing the window and reopening it was fixed. I’ll make a copy of my user library XML file before editing it for any future issues. All’s well that ends well, thank you for your help.

You can make the edits to the user library yourself in Library > Instruments. The easiest way is to start a new empty project, then go to the instrument editor, and find the instrument in question. You should see that the star in the action bar is illuminated/filled, which indicates that the selected instrument is saved in the user library. You can “un-save” it from the user library by clicking the star so that it becomes unfilled, or you can edit the definition of the instrument (including its name) and then click the star button again to ensure that the user library is updated.

Thank you! That’s just what I was looking for.

@dspreadbury I just answered a similar question on the Facebook group:

It seems odd to me that in the (Library > ) Instruments Editor it’s possible to restore the factory names of instruments, but it’s not possible to then Save As Default. It’s possible to Save As Default from the left panel of Setup mode > Edit Names, but it’s not possible to revert to factory settings from there (except by manually typing, and I see too many client projects where someone else has erroneously attempted to confim the dialog with Enter, resulting in a stray line break).

In a future version please could it be made possible to both restore factory instrument name settings and remove the user library overrides from the same place?

You can save entire instrument definitions, including their default names, as default via Library > Instruments. You can also reset an instrument back to its factory settings, including its name, via Library > Instruments: click the little “revert” button in the action bar.

It’s non-obvious, but the workflow to correct this kind of case via Library > Instruments would be to click the filled star button to remove the saved instrument from the user library. If you have the instrument in the current project, you can then click the revert button to return the instrument to its factory state. I grant you that this will reset all of its settings, not only its name.

We could potentially add a “revert to factory” button to the Edit Instrument Names dialog in future.

I think the non-obvious bit, at least from my perspective, is that if you unstar in the action bar, the user library isn’t actually updated until you hit OK and leave the Instrument Editor. That means that if you don’t leave the Instrument Editor but hit the Revert button, it reverts to the previously saved override (in this case the Erhu name).

(Thank you, though, as I do now know a bit more than I knew an hour ago.)